February 29, 2024, 04:15:18 AM

News : LinuxSolved.com Linux Help Community Forum..


Recent Posts

Pages: [1] 2 3 ... 10
1
Os Talk / Re: Why I am moving to linux
« Last post by TerryGetto on May 08, 2023, 10:10:36 AM »
Apologies for reviving this thread, but I just wanted to give my two cents. Congrats on your decision to move to Linux! It's definitely a great choice if you're tired of viruses and slow PCs. I totally understand the feeling of being overwhelmed with all the different versions out there but don't worry, you'll find one that suits you best. Just pick one that seems appealing and start exploring! However, I want to note that I recently tried the latest version of Windows and was very pleased. If you're interested, you can try it out too by using cheap windows keys from reliable sources or communities. But of course, if you're already set on Linux, that's great too! Good luck with your transition!
2
Os Talk / Re: Why I am moving to linux
« Last post by JasonJames on May 08, 2023, 09:59:38 AM »
I'm thrilled to hear that you've made the decision to switch to Linux! It's a fantastic operating system that has a lot of benefits, so I'm sure you're going to love it. Choosing the right version of Linux can be a bit of a challenge, especially if you're new to the system. But don't worry, there are plenty of resources available to help you make an informed decision. And once you get the hang of it, you'll find that Linux is incredibly powerful and versatile. Learning the Linux "lingua franca" can take some time, but it's a fascinating journey. Linux has a rich history and culture, and there's always something new to learn.
3
I would also like to hear ideas
4
No ideas?
5
Hello I have a question that might not be easy to understand or to answer.

I am trying to build a live OS to run a custom aplication.
For that I am using:
1) debootstrap/chroot to build/assemble the a minimal Linux OS
    1.1) Install a kernel
    1.2) Configure and install all the packadges needed
    1.3) Add all the custom application files and scrips
2) mksquashfs to make the image
3) xorriso to make the iso

But I need to protect the custom aplication files (or at least make it dificult to access and read them)

Is there a way to encript the ISO and allow it to run without the user having to input the password?
If there is can you give me any pointers on how to do that?

Thank you.
6
Linux Installation Support / Re: configure: error: !!! no tgetent - no screen
« Last post by soumitra on January 19, 2022, 09:05:18 AM »
The option you are looking for is --enable-install-termcap
7
Linux Installation Support / Unable to dual-boot in to Ubuntu
« Last post by maximealexandre on October 13, 2020, 03:58:02 AM »
Hello guys, I have a Huawei MateBook 13 that comes with Windows home edition. Today for the second time I tried to install Ubuntu (dual-boot) in to it and so I made my Kingston USB drive bootable with Etcher following their tutorial and installed Ubuntu successfully. I allocated a brand new partition for Ubuntu. But the issue is I am unable to actually dual boot it. It doesn't allow me to switch between operating systems and it just boots straightaway to my old Windows operating system. After the first installation, I thought I did something wrong so I re formatted the drive and installed the system again but it didn't fix the issue. I even asked from Stack Overflow and they suggested to adjust some BIOS settings but still the issue remains. Any advice you could give would be much appreciated.


8
Miscellaneous / Centos 7 - no message log at all in /var/log- all blank
« Last post by Saahib on May 18, 2020, 08:26:01 PM »
Hi,

Today I noticed that one of the Centos server I used, there are no logs being updated. Log rotation is working as but all current files are blank.
Nothing in
/var/log/messages
/var/log/maillog

Some logs are working like /var/log/lfd.log ( I am using csf firewall).

I have been going through various topics online where people might have deleted or messed up permission of /var/log folder. But nothing so far . I even did side by side comparison of permission with a similar server. I don't see anything messed, all is good. Interesting thing is that everything is working fine.

Following online advices, I reinstalled rsyslog as it may fix the permission if they are messed:
Code: [Select]
yum remove rsyslogThen
Code: [Select]
yum install rsyslog
Checking rsyslog status say its running .
Interesting thing is that even though no logs are being logged, all services are running fine on server. I think its more than 2 weeks since they are not working.

Is there any command or system to restore default permission of /var/log  ?

I don't want reinstall, it will be lots of headache given amount of data on the server.
9
Linux Servers Support / Re: Regular user Can't SSH using public Key but root can
« Last post by Saahib on May 18, 2020, 08:16:11 PM »
Oh man, it was driving from many days, it was indeed permission problem . I had checked actually , permission were 644 and ownership was also correct (owned by the user) however.

Looking around I found that we need following permission, I am sharing here for future reference:
Code: [Select]
chmod 700 ~/.ssh
chmod 600 ~/.ssh/authorized_keys

Problem was that I was comparing permission with root .ssh and its content but that doesn't work for regular user.
10
Linux Servers Support / Re: Regular user Can't SSH using public Key but root can
« Last post by dalek on May 18, 2020, 01:46:12 AM »
I would check permissions of the key files and also check to be sure the user is a member of the correct groups.  I haven't used ssh in ages but seem to recall it requiring being a member of a certain group.  Given your output, it seems to be trying so that leads me to believe it is a permission issue with the key files.  I'd suggest setting it to be readable by all but only writable by root.  It may be that it can see the file exists but is unable to read the contents of the file. 

Hope that helps.
Pages: [1] 2 3 ... 10