July 13, 2024, 10:20:18 PM

News : LinuxSolved.com Linux Help Community Forum..

Author Topic: SOLVED - Kernel boot options removed by fault, no boot options  (Read 11274 times)

Offline cdt

  • New Member
  • Posts: 3
Hello Everyone,

First of all, I highly appreciate all Linux forum members and whole Linux community. ;). I wish you the best for all of you !

I will try to be short and concise: I am using Linux Mint 10 for 2 months on 2 ws, and all went good so far (Vbox, developing, Unix scripting, etc); I am not a very beginner in UNIX, having some skills in PHP/MYSQL/APACHE/BASH/LINUX - WIN/BATCH as well (several years, let's say).

But what is happening now, :( is putting me into a trouble: yesterday I have performed some wifi kernel modules installation with Synaptic and some new kernel were added to boot menu, some of them with --recovery option, some of them new ones. Uninstalling these last wifi modules (and probably another ones), all kernel modules (including the current (and good) one were uninstalled, of course, they disappeared from the boot menu as well).

I agree that was totally my fault because I have installed wifi modules which have required kernel recompiling, but I dd not know then the full image of this disaster.

In the last open session (just before reboot), I have seen that all kernel images/module disapperared from /root folder, /vmlinuz file disappeared too; of course using GUI boot loader, I have observed only 2 Memory test options and the M$Win OS (the second OS installed).

My issue now is: I would like to repair the previous Mint 10 installation, no to reinstall because it is taking some time to reparameter all settings .. if it is possible.

> I have a Linux Mint 10 burned disk (this one where I typing these lines);
> wired/wireless network on;
> all partitions are not changed
> Linux Mint boot menu has only 2 Mem test option + 1 M$Win OS boot option
> Old Linux kernel definitions is missing from boot menu as well as from:
/root folder
in the / [root] there is no any vmlinuz binaries (I don't remember the correct name for the vmlinuz ..)
> I am able to burn any CD/DVD's, download any binaries/apps from the internet and so on.
> I am online now, ready to give you all details you need about my steps performed yesterday (as much as I remember ;(( -- poor of me ...)

> I would like to avoid the full reinstallation in order to keep the old and full Linux Mint 10 destop;
> I would like to repair the linux kernel, putting it in the right place (/root, /) and create again the records in boot menu, in order to boot again LM10 as it was until yesterday evening.
> Hoping that this problem could have a solution, would you be kind to advise me a good procedure to peform (to install) as this kernel changes to do not happen again in the future.

Hoping that someone of you has encountered this before, I am here to follow your instructions. If the name of this topic could be redefined (in order to reflect this issue better), please do so or suggest me to do, I have not used so much the discussion forums until now, but I will do from now on :) ...

All the best for you.

« Last Edit: September 09, 2011, 04:46:46 AM by cdt »

Offline cdt

  • New Member
  • Posts: 3
Re: Kernel boot options removed by fault, no boot options
« Reply #1 on: June 19, 2011, 07:57:09 PM »
Hello Guys,

It's me again, with an update: after many days efforts, it seems that the kernel is ok, installed, but GRUB2 boot options are the real problem.

Now, GRUB2 has only /Mem test boot option and the 2nd OS boot, MS Winxp. The LinuxMint 10 boot options are vanished, due my previous poorly actions :(.

So, I tried with Super Grub Disk, booting from USB, but some errors encountered. Perhaps due the ext2 fs that was on LM10 main partition. I tried then to convert to ext4: it's seems to be managed this, but continuing with SGD, I was not able to repair the Grub2 boot menu to include the LM10 installed on /dev/sda7.

Then I followed someone on the forums suggestion to use the SourceForge boot script to capture all from my system (info, etc), post them here and then to wait another suggestions.

Here they are, the output of the script and I am rephrasing the issue:
<> I cannot boot the Linux Mint 10 installation on /dev/sda7, because this boot record was deleted from GRUB2;
<> I am not able yet to repair myself the Grub2, due my minimal GRUP skills ..;(.
<> all other boot options are ok;
<> I am able to boot from USB/cd live LM10, or Super Grub Disk, or any required distro.

Thanks all for attention and for a useful idea.

Output of the script is here:

Hello Guys,

Thank you for attention. It's seems that only this is remaining to try, because any other hadn't worked.
So, here you are the result of this script, please help me to add the <linux mint 10 on /dev/sda7 partition, on the Grub2 boot Menu).

It seems that this is the real problem, my last actions removed the entries of the LM 10 from the Grub2 menu (and probably do another changes).

Please let me know if should I try any other settings.

                  Boot Info Script 0.60    from 17 May 2011
<start of the script>

============================= Boot Info Summary: ===============================

 => Syslinux MBR (3.00-3.35) is installed in the MBR of /dev/sda.
 => Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows XP
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  Windows XP
    Boot files:        /boot.ini /ntldr /NTDETECT.COM

sda2: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows XP
    Boot sector info:   According to the info in the boot sector, sda5 starts
                       at sector 63.
    Operating System: 
    Boot files:       

sda6: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Linux Mint 10 Julia
    Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.03 2010-10-22 ........>..sr>.......CN.8...0...~.....~...f...M.f.f....f..0~....>E}.u......
    Boot sector info:   Syslinux looks at sector 7247792 of /dev/sdb1 for its
                       second stage. SYSLINUX is installed in the  directory.
                       No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files:        /syslinux.cfg /ldlinux.sys

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *             63   204,800,399   204,800,337   7 NTFS / exFAT / HPFS
/dev/sda2         204,800,461   488,396,799   283,596,339   f W95 Extended (LBA)
/dev/sda5         204,800,463   215,293,679    10,493,217   7 NTFS / exFAT / HPFS
/dev/sda6         484,397,056   488,396,799     3,999,744  82 Linux swap / Solaris
/dev/sda7         215,293,952   484,390,911   269,096,960  83 Linux

Drive: sdb _____________________________________________________________________

Disk /dev/sdb: 4051 MB, 4051697664 bytes
151 heads, 42 sectors/track, 1247 cylinders, total 7913472 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sdb1    *         16,128     7,913,471     7,897,344   b W95 FAT32

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/sda1        F6EC84C8EC848499                       ntfs       SYSTEM
/dev/sda5        1668294868292847                       ntfs       swap
/dev/sda6        9febc5b0-cc7a-46a7-9ec3-ef3b76f2e259   swap       
/dev/sda7        b84d7500-383f-47de-8e42-263738a90d0a   ext4       
/dev/sdb1        5CD0-049E                              vfat       4GBGREEN

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sdb1        /cdrom                   vfat       (ro,noatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)

================================ sda1/boot.ini: ================================

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

=========================== sda7/boot/grub/grub.cfg: ===========================

# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
set default="2"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true

function savedefault {
  if [ -z "${boot_once}" ]; then
    save_env saved_entry

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi

function load_video {
  insmod vbe
  insmod vga

insmod part_msdos
insmod ext2
set root='(hd0,msdos7)'
search --no-floppy --fs-uuid --set b84d7500-383f-47de-8e42-263738a90d0a
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=1024x768
  insmod gfxterm
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos7)'
search --no-floppy --fs-uuid --set b84d7500-383f-47de-8e42-263738a90d0a
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
  set timeout=10
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
insmod part_msdos
insmod ext2
set root='(hd0,msdos7)'
search --no-floppy --fs-uuid --set b84d7500-383f-47de-8e42-263738a90d0a
insmod png
if background_image /boot/grub/linuxmint.png ; then
  set color_normal=white/black
  set color_highlight=white/light-gray
  set menu_color_normal=white/black
  set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos7)'
   search --no-floppy --fs-uuid --set b84d7500-383f-47de-8e42-263738a90d0a
   linux16   /boot/memtest86+.bin
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos7)'
   search --no-floppy --fs-uuid --set b84d7500-383f-47de-8e42-263738a90d0a
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
   insmod part_msdos
   insmod ntfs
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set f6ec84c8ec848499
   drivemap -s (hd0) ${root}
   chainloader +1
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
### END /etc/grub.d/41_custom ###

=============================== sda7/etc/fstab: ================================

# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda7 during installation
UUID=b84d7500-383f-47de-8e42-263738a90d0a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=9febc5b0-cc7a-46a7-9ec3-ef3b76f2e259 none            swap    sw              0       0

=================== sda7: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

 188.801685333 = 202.724265984  boot/grub/core.img                             1
 109.151569366 = 117.200605184  boot/grub/grub.cfg                             1
 102.854846954 = 110.439550976  boot/initrd.img-2.6.35-22-generic              2
 102.854846954 = 110.439550976  initrd.img                                     2

============================== sdb1/syslinux.cfg: ==============================

default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit file=/cdrom/preseed/mint.seed boot=casper quiet splash --

label ubnentry0
menu label Start Linux Mint
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz file=/cdrom/preseed/mint.seed boot=casper  quiet splash --

label ubnentry1
menu label Start Linux Mint (compatibility mode)
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz file=/cdrom/preseed/mint.seed boot=casper xforcevesa  ramdisk_size=1048576 root=/dev/ram rw noapic noapci nosplash irqpoll --

label ubnentry2
menu label Check the integrity of the CD
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=casper integrity-check  quiet splash --

label ubnentry3
menu label Memory Test
kernel /isolinux/memtest
append initrd=/ubninit

label ubnentry4
menu label Boot from local drive
kernel /ubnkern
append initrd=/ubninit


================= sdb1: Location of files loaded by Syslinux: ==================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             ldlinux.sys                                    1
            ?? = ??             menu.c32                                       1
            ?? = ??             syslinux.cfg                                   1

============== sdb1: Version of COM32(R) files used by Syslinux: ===============

 menu.c32                           :  COM32R module (v4.xx)

<end of the script>

Offline cdt

  • New Member
  • Posts: 3
final issue description and thread closure
« Reply #2 on: September 09, 2011, 04:47:03 AM »
Hello all,

so, after more time spent to solve, I got (I suppose) the issue:
- during the installation/uninstallation of some Wifi components, a new kernel was installed; after the uninstallation, I was not able to update Grub2 to repoint to the old one.
- at the first boot the access was not possible.

All solution got from community indicated to use /usb or /cd boot, then to mount --bind the important dev's then try to update or fix Grub2. Using Software installer or apt-get I was not able to install the good kernel so I given up.

Anyway, thank a lot for attention.