September 26, 2021, 01:31:43 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: keyboard default setting  (Read 8877 times)

Offline mliu

  • Tux Awared
  • **
  • Posts: 30
keyboard default setting
« on: April 08, 2005, 03:11:24 PM »
Hi, there.
I am using Fedora 1. Every time I start my computer, the NumLock button is default off.
Is there any command/configeration I can change that default setting into on automaticlly?
Thanks in advanced.

Offline dragoncity99

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 551
keyboard default setting
« Reply #1 on: April 08, 2005, 04:08:56 PM »
U could try switching of the numlock first,
then, when u logout, check the save settings option. And it will remember ur last state.

Hope this works :)

Offline anil_garg5

  • Linux Learner
  • ***
  • Posts: 71
keyboard default setting
« Reply #2 on: April 11, 2005, 12:32:02 PM »
you have to change BIOS setting for this.....

Either Press Del or F2 to enter BIOS configuration depending for your motherboard make.

select the numlock option whatever to want.
save the setting.

Offline mliu

  • Tux Awared
  • **
  • Posts: 30
keyboard default setting
« Reply #3 on: April 12, 2005, 11:44:50 PM »
Thanks guys.
However, I do not think it's the problem of BIOS setting. Since if I log in ms windows 2000, it is ok.  Just the Ferora does not remember my setting all the time. I remember somewhere in initrc I can changed it. Can anybody tell me please?
Thanks in advanced!

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
keyboard default setting
« Reply #4 on: April 13, 2005, 11:51:34 AM »
Well.. sorry here but Its somewhere in X config file :D .. Actually never bothered about such thing so cant remember clearly and these days I am also away from my LINUX box :(

Offline anil_garg5

  • Linux Learner
  • ***
  • Posts: 71
keyboard default setting
« Reply #5 on: April 13, 2005, 11:55:17 AM »
You have to use setleds command from the command prompt in linux



#setleds
it shows  the defaults setting the keyboard LEDs.

#setleds +num
It command work on my fedora sytem to ON setleds command on

You can write this command in /etc/rc.d/rc.local


For more details, go thru the link
http://www.linux.com/howtos/Keyboard-and-Console-HOWTO-10.shtml

Hope this will work for you.

Offline mliu

  • Tux Awared
  • **
  • Posts: 30
keyboard default setting
« Reply #6 on: April 13, 2005, 12:38:25 PM »
Dear Anil:
Thanks for the info. It's really useful.
One more thing is that I am using a Microsoft Multimedia keyboard so I have a lot of buttons. Can you tell me how to set them into the function like "I press a Mail button and my default mail agent will auto open"? Is it possible to do some under Linux?
Thanks in advanced again :-)

Offline anil_garg5

  • Linux Learner
  • ***
  • Posts: 71
keyboard default setting
« Reply #7 on: April 14, 2005, 05:50:31 AM »
Dear

These MM keyboards are windows specific .
I donot think  I will work in Linux...
I will work out it and let u know .
 :roll:

Offline debashis

  • New Member
  • Posts: 2
keyboard default setting
« Reply #8 on: July 08, 2005, 02:27:51 PM »
Quote from: "mliu"
Dear Anil:
Thanks for the info. It's really useful.
One more thing is that I am using a Microsoft Multimedia keyboard so I have a lot of buttons. Can you tell me how to set them into the function like "I press a Mail button and my default mail agent will auto open"? Is it possible to do some under Linux?
Thanks in advanced again :-)

Offline debashis

  • New Member
  • Posts: 2
keyboard default setting
« Reply #9 on: July 08, 2005, 02:28:49 PM »
please

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
keyboard default setting
« Reply #10 on: July 09, 2005, 07:08:34 AM »
So you have same question as mliu ?

Well for that you should look out for its driver ..b'coz i don't remember any way of doing same.