December 07, 2021, 12:43:39 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Connecting a CDMA usb modem to access internet  (Read 7110 times)

Offline Ramsubbu

  • New Member
  • Posts: 2
Connecting a CDMA usb modem to access internet
« on: December 13, 2008, 01:30:56 PM »
Dear experts,

I am new to Ubuntu 8.04. I have been using(in XP) Reliance Netconnect for internet when I travel. Now I want to use this modem in Ubuntu. I have gone to a number of tutorial sites and did almost everything they suggested. Still it doesnt work. Here is the output from the wvdial in terminal:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT 230400
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Dec 13 18:56:32 2008
--> Pid of pppd: 8133
--> Using interface ppp0
--> Disconnecting at Sat Dec 13 18:56:42 2008
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

My wvdial.conf file reads like this:
[Modem0]
Modem=/dev/ttyUSB0
Baud=115200
SetVolume=0
Dial Command = ATDT
init1=ATZ
FlowControl= Hardware (CRTSCTS)
[Dialer Defaults]
Username=xxx
Password=xxx
Phone=#777
Stupid Mode= 1
Inherits = Modem0

I have also downloaded the gnome-ppp and tried. didn´t work.

Please advise what I should do.
Thanks in advance.
Ramsubbu.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting a CDMA usb modem to access internet
« Reply #1 on: December 13, 2008, 11:11:45 PM »
Hello,

What is output of :
Code: [Select]
wvdialconf /etc/wvdial.conf
Secondly, try to add following in your config file after init1=ATZ
Code: [Select]
init2=AT+CRM=1 

Offline Ramsubbu

  • New Member
  • Posts: 2
Re: Connecting a CDMA usb modem to access internet
« Reply #2 on: December 14, 2008, 12:59:15 AM »
Thanks for the reply. I had tried that too. ( init2=****).

The output for the wvdialconf is:

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0   S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- ERROR
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf.tmp6432': Permission denied
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf' ('/etc/wvdial.conf'): Bad file descriptor
ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

Also as per some other posting in ubuntu forums (http://ubuntuforums.org/showthread.php?t=986011&highlight=ec325), I changed the wvdial.conf to:
[Modem0]
Modem=/dev/ttyUSB0
Baud=115200
SetVolume=0
Dial Command = ATDT
init1=ATZ
FlowControl= Hardware (CRTSCTS)
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
ISDN = 0
Phone = #777
New PPPD = yes
Modem = /dev/ttyUSB0
Username = xxx
Password = xxx
Baud = 460800
 Even now it doesn´t work. Saying probably bad account/password. I know it for sure the username and pw are correct as it works in windows. The output for wvdial is:
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT 230400
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sun Dec 14 06:36:10 2008
--> Pid of pppd: 6952
--> Using interface ppp0
--> pppd: `�[06][08]x�[06][08]
--> pppd: `�[06][08]x�[06][08]
--> pppd: `�[06][08]x�[06][08]
--> pppd: `�[06][08]x�[06][08]
--> pppd: `�[06][08]x�[06][08]
--> pppd: `�[06][08]x�[06][08]
--> Disconnecting at Sun Dec 14 06:36:20 2008
--> The PPP daemon has died: Authentication error.
--> We failed to authenticate ourselves to the peer.
--> Maybe bad account or password? (exit code = 19)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 19)


Thanks again
Rams.
« Last Edit: December 14, 2008, 01:08:16 AM by Ramsubbu »

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting a CDMA usb modem to access internet
« Reply #3 on: December 16, 2008, 11:21:54 AM »
Since now I do not have any CDMA modem I can't tell precisely that what you need to do.

But I guess, use first wvdial and change INIT strings as you found on modem initialization. Also, try with baud rate 9600 also.