December 14, 2017, 09:59:34 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Setting up LAMP on CentOS 6  (Read 1888 times)

Offline jtt89

  • Linux Noob !
  • *
  • Posts: 8
Setting up LAMP on CentOS 6
« on: November 19, 2011, 11:44:12 AM »
I was able to conect Centos6 on Virtual Box to Windows (I can to ping in both directions) with Host-only Adapter (for connection between the two) and NAT Adapter (to enable Linux on VB to connect to the Internet). I want to set up httpd, mysql and vsftpd servers and in the end easily connect to httpd from Windows based browser and ftp server with a Windows based client as well. I would also want to have access through SSH.
 
I have a general idea of the steps that are involved, but there is also a configuration that I am not sure about at this point. Lets say I follow these steps:
 
# yum install httpd
# yum install php php-pear php-mysql
# yum install mysql-server
# mysql_secure_installation
# yum install vsftpd
# yum install mod_ssl
 
Technically, I have everything installed, but what would be the next steps that I need to take (from the networking point of view, so to speak) to get it all working)?
 
I know I need to configure, at least Apache, and ftp server, but I am not sure how is it gonna work; like where am I gonna be uloading the sites (I know this can vary), how am I gonna know what address to use in a browser if I wanna go to a website x, y, z on that installation etc. This sounds like I need to do some kind of DNS setup and I am kind of stuck at this point.
 
If somebody could give me a general outline of what are the things that need to be done that would be great (I was looking at a lot of websites and I know about etc/sysconfig/network, httpd.config - not too much about it on Apache's site, hostname, hostname -f etc; but it is kind of hard to piece it all together at this point). I am gonna be looking at the books also, but they not always reflect the setup that I have too (VirtualBox).
 
Thank you.
« Last Edit: November 23, 2011, 11:49:16 PM by jtt89 »

Offline jtt89

  • Linux Noob !
  • *
  • Posts: 8
Re: Setting up LAMP on CentOS 6
« Reply #1 on: November 24, 2011, 10:08:24 AM »
I read somewhere that I should be able to connect to the guest (Linux) with Putty. I tired and I was not able to. I also looked at all the network configuration info (ipconfig /all and ifconfig) and that information has changed also. I keep making screenshots, because it is hard to keep track of it when I am not sure how is it suppose to work (pictures are here VirtualBox Configuration)

After the installation I was using (I think) 192.168.56.1 to ping host (Windows) from Linux and 192.168.56.101 the other way.
Today I think it should be 169.254.230.113 (ping from Linux) and 192.168.56.101 (the same, ping from Windows to Linux). So it gets confusing quickly.
Based on above information I was trying to use Putty with 192.168.56.101 as an address and that did not work...

(Host-only network is basically the network that needs to connect Windows and Linux)

Offline gauravbajaj

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 658
Re: Setting up LAMP on CentOS 6
« Reply #2 on: December 21, 2011, 10:20:52 PM »
if you wana ping between these hosts then they should belong to same nertwork class (192.168 or 169.254. ) . Also try to give same class ur Linux box  the same NW class ip i.e in range ( 192.168 - please make sure ur windows ip belongs  to same NW) . Try to give static ip  Moreover , I believe there is an option in virtual box under settings , NAT or bridge ..id ont remember. but I am pretty sure that one of them would work . ( I belive NAT) . Try that and see if it helps