June 25, 2018, 04:28:03 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Sarg reporting  (Read 4376 times)

Offline hmeyering

  • New Member
  • Posts: 3
Sarg reporting
« on: September 26, 2008, 04:42:18 AM »
Hi there,

I am a first time user of Sarg and have tried to install it using the rpm file, which looked fine.

Didn’t do any configurations and trying to run a report. It gets to 100% and just sits there forever, doesn’t produce any report.

Any ideas what I need to do or what configuration needs to be done before doing reports? Would really appreciate the help.

Thanks
Hendrika Meyering
Pinelands High School

Offline aktiwari4u

  • LST CareTaker
  • Crescent
  • *****
  • Posts: 161
    • http://aktiwari4u.tk/
Re: Sarg reporting
« Reply #1 on: September 27, 2008, 03:34:34 AM »
the reports are automatically generated at the default out put location by default it is some where at webdirectory. check your default output location .

Offline hmeyering

  • New Member
  • Posts: 3
Re: Sarg reporting
« Reply #2 on: October 06, 2008, 05:39:48 AM »
Hi there,

Thanks for the reply.
I am not understanding what you are asking. Remeber that I know where the reports are put on the server (/var/www/sarg/ONE-SHOT/) but reporting starts in but never finishes. It seems to not be doing anything

Any ideas?
Hendrika

Offline hmeyering

  • New Member
  • Posts: 3
Re: Sarg reporting
« Reply #3 on: October 06, 2008, 07:09:51 AM »
Hi there,

I am also getting the following error.
sort: open failed: /tmp/sarg/mju.uzsyhk,_p[.log /tmp/sarg/mju.uzsyhk,_p[.unsort: No such file or directory

It gets stuck after that and doesn't go any furter. What can I do to fix it so it finishes the report.
I also find that it starts from my last access.log file. Will it eventually go through all of the access.log files or will it only do access.log.3. If so where does this get set because in webmin I tell it to do all.

Hope you can help.
Hendrika

Offline aktiwari4u

  • LST CareTaker
  • Crescent
  • *****
  • Posts: 161
    • http://aktiwari4u.tk/
Re: Sarg reporting
« Reply #4 on: October 21, 2008, 12:33:49 PM »
i suppose that in your sarg file the location of the log file is not defined correctly you need to check that .
the location what you are talking is the output location for the resultent file of the sarg . while to process it need the squid.log file. so for input you should defile your squid log file.
« Last Edit: October 21, 2008, 12:35:27 PM by aktiwari4u »