Network Troublshooting > Linux Proxy Server Support

failed to make swap directory /cache---squid

(1/2) > >>

hi linux grp...
       I tried to insatll    "squid-2.5.STABLE13"  in linux enterprises edition ...
     after configuration while i was execting command  " /usr/local/squid/sbin/squid -z
    it says some errors  like

[root@localhost ~]#  /usr/local/squid/sbin/squid -z
2006/04/25 02:08:00| Creating Swap Directories
FATAL: Failed to make swap directory /cache: (13) Permission denied
Squid Cache (Version 2.5.STABLE13): Terminated abnormally.
CPU Usage: 0.001 seconds = 0.001 user + 0.000 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
can anyone help me... to resolve this issue .pls.....

thanking u

Just check owner of /var/spool/squid directory

it must be squid

if not change the owner like this

#chown squid:squid /var/spool/squid

After that , Just run this command (Important Step)

#restorecon -R /var/spool/squid

Just restart the service of squid

#service squid restart

It will definitly run,If still u will face any problem,let me know


Hi gaurav tq for u r reply...
   i have done what u  doesnot give any error..
after that if  i run   "/usr/local/squid/sbin/squid -z " it gives same error ...and

 but i cudnot findout  "cache.log " file in  "/usr/local/squid/var/logs/" ....
what may be the problem...

    w8ing for u r reply

its very common error,
goto /usr/local/squid/sbin/squid and delete every dir. and file under it then change the permission and ownership.

I assume that squid has a usergroup as squid and a user squid.

--- Code: ---chown squid:squid /path/to/cache

chmod 770 /path/to/cache
--- End code ---

hi ricky
ther is no directory named squid"  under  " cd /usr/local/squid/sbin/ has a file named squid ....thus nothing is ther to remove ...
so i tried  the commands which are suggested by u......under the dirrectory /usr/local/squid/sbin/  ....then it says an error messages

[root@localhost sbin]# chown squid:squid /path/to/cache
chown: cannot access `/path/to/cache': No such file or directory

[root@localhost sbin]# chmod 770 /path/to/cache
chmod: cannot access `/path/to/cache': No such file or directory

thus how can i overcome this problem? ....
thanking u ...

** iam using redhat linux enterprise edition and squid version is "squid-2.5.STABLE13.tar.gz"


[0] Message Index

[#] Next page

Go to full version