April 16, 2024, 05:09:26 AM

News : LinuxSolved.com Linux Help Community Forum..

Author Topic: WinRAR giving me hell  (Read 4154 times)

Offline loganrtfm

  • New Member
  • Posts: 1
WinRAR giving me hell
« on: September 29, 2009, 03:29:58 AM »
I'm new to linux, using redhat 9 for now until I decide which distro is the right one for me. I'm trying to use command line as much as possible so I can actually learn rather than having a GUI do all the work for me.. I'm kinda weird, i just want to know how to actually do things and I want to learn this operating system for no real reason at all, just curiousity and boredom..

I first installed the latest WinRAR for linux (3.9) but everytime I try to use unrar I get this error
unrar: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
I read  that I needed to install an earlier version of WinRAR so I downgraded to v3.6 but i'm still getting the same error... What can i do? I've spent over a couple  hours using search engines and using forums and haven't found any answers, so I was hoping you guys could help :)

Thx everybody and I look forward to getting to know this O/S a little better!!

Offline kaushalpatel1982

  • LST CareTaker
  • Linux Learner
  • *****
  • Posts: 87
Re: WinRAR giving me hell
« Reply #1 on: September 30, 2009, 11:31:50 AM »

I think you should use latest version for the  linux, because it comes with the latest packages.

Redhat 9 is too old version that might not have any support channel.

If you want dig for the librery file go for RPMForge. that might help you.

best of luck

Offline dragoncity99

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 551
Re: WinRAR giving me hell
« Reply #2 on: October 29, 2009, 05:15:12 PM »
Sounds like your library incompatible with the one in WinRAR.

or possibly, try to do ldconfig first and run again.

If it still doesn't work. try to use LD_LIBRARY_PATH to overridge it and specify the actual library file to it. Dangerous!