February 25, 2024, 05:45:03 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Squid or DNS problem  (Read 2934 times)

Offline marius_vl

  • New Member
  • Posts: 1
Squid or DNS problem
« on: February 19, 2007, 05:18:23 PM »
Hy,

I have a Centos 3 server installed with qvcs, NAT and DNS packages. I wanted to block www.meebo.com and I installed squid for this. It seems to work but I receive a lot of TCP_MISS when users acces the net. I don't know why but it seems to work even with this.

The problem is now that some users must acces some sites like preview.my-site.com that are not listed in the DNS, where are posted. Before I installed squid they could acces it by puting in Windows/Sustem32/Drivers/etc/hosts the ip addres and the name of this previews and it worked. Afther I installed squid it doesn't work, on the logs I see the TCP_MISS/503 error. The regular TCP_MISS were with /200 error. If I stop squid it works again.
I tried to put those ip and names in /etc/hosts on the server but it still doesn't work.


Thanks to all

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Squid or DNS problem
« Reply #1 on: February 20, 2007, 08:56:56 PM »
Hmm.. btw.. TCP_miss broadly means that squid doesn't find anything related to that in its cache and data was directly retrived from internet and thts normal.

Now about second issue.. squid is using nameserver available to linux box to do DNS queries. May be you can try to add following in /etc/resolv.conf if its not there.
Code: [Select]
nameserver 127.0.0.1

Also please show here how you added entries in /etc/hosts