December 05, 2023, 10:07:15 PM

News : Linux Help Community Forum..

Author Topic: Mounting Floppy  (Read 7498 times)

Offline Nazareth

  • Linux Noob !
  • *
  • Posts: 10
Mounting Floppy
« on: January 23, 2004, 11:07:46 AM »
Good morning everybody,
greetings from the Netherlands.

After many attempts I succeded in install linux (mandrake 9.2 ) as a daul boot with w.98 on my pc, but the problem is that I am unable to  the floppy drive .I tried the following :

1) Opeing a root console ,typing the root password , the # prompt appeard the typein the following command :

2) with the use of the following command :

 mount -t  vfat /dev/fd0 /mnt/floppy , hier is also nothing changed,more -
over I got a message that the /mnt /floppy does not exist in the /etc/fstab
or in /mtab file .

3) By using the command  cat /etc/fstab  ,I can see the partitions ,but
infront he floppy or the cd-rom  I see  the following :

none /dev/fd0 ...etc ... ( the same for the cd-rom ) .

4) I tried to make a dirctoy for the floppy in the /fstab by using the command  # mkdir /dev/fd0 (after Iadded my name in the administrators group and root group ). also nothing changed.

May some of you guys have an idea or anadvice that can show me the way ...????.... :cry:  :cry:

Thnx in advance


Offline aaa

  • Tux Awared
  • **
  • Posts: 38
Mounting Floppy
« Reply #1 on: January 23, 2004, 06:28:05 PM »
none /dev/fd0 ...etc ... ( the same for the cd-rom ) .
Mandrake uses the supermount program to mount automatically. Lines in fstab that have 'none' in front of them where they would normally have a device and have type 'supermount' are being maintained by supermount. To mount, just go the mount-point (second field in the device's fstab line, most likely /mnt/floppy).
/dev/fd0 is not a directory, it is a device file. The mountpoints tend to be in /mnt.

Offline dalek

  • LST CareTaker
  • Crescent
  • *****
  • Posts: 243
Mounting Floppy
« Reply #2 on: January 25, 2004, 12:08:31 AM »
If it is still giving you problems, reboot just to make sure there is nothing left over from your earlier tries and then from command line type in this.

Code: [Select]
ls /mnt/floppy  That is a lower case L, short for list I guess.

It should then mount, using supermount, and list the contents of the floppy.  BEFORE you remove the floppy, or CDROM, it is a good idea to type in cd / to take you back to a directory that is outside of the floppy.  In Mandrake 9.1, I have to close Konqueror to get supermount to umount correctly.

Supermount is nice but it can give you problems if not used correctly.  It is better than having to type in mount this and mount that though.  I switched to Gentoo and no supermount, yet.

If you don't like supermount, it can be disabled.  If you are going to use supermount, let it mount the drives.  If you do it manually you can cause problems when you try to umount.  It will give a error that what you are typing does not match mtab and will not umount the drive.  I had to reboot once to get a CDROM out.  Me newbie then.   :oops:  :oops:   DO NOT mess with mtab.  You can look but NEVER change anything in there unless you are sure you know what you are doing.  I would leave that file alone.

Hope this helps.


 :D  :D  :D