December 16, 2017, 10:58:37 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Not able to install Reliance LG phone on SuSE 9.0 Live Eval  (Read 6885 times)

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Hi,
 I want to access the internet from SuSE 9.0 Live Eval (boots off a CD) using the LG LSP-340E.

So first I tried out the R-Connect software for Linux provided at the Reliance website relianceinfo.com/Infocomm/html/rservices/rservices_linux_rconnect.html

I downloaded it, untarred it and finally when I executed the install.sh script given, everything went fine until I was given the choices of COM1 and COM2 for the phone/modem. Since it is installed under COM1 in Windows I entered that only. But rigth next I started getting these messages:-

Code: [Select]
wc:/var/log/messages:No such File or Directory
tail:/var/log/messages:No such File or Directory
tail:/var/log/messages:No such File or Directory
tail:/var/log/messages:No such File or Directory

This block of messages started appearing in an infinite loop after every gap of 5 seconds until I had to get back to the prompt by Ctrl+Break.

It looks like the log daemon doesn't create the standard file /var/log/messages in SuSE Live Eval during bootup. And I think the install.sh script needs this file crucially for correct execution.


Anyway, this didn't work so I tried this solution given on this Website itself
Using Relicance phone as modem for Internet
After filling my /etc/wvdial.conf with the given details and executing the command
Code: [Select]
wvdial reliance   I got this output but no connection to the net:-

Code: [Select]
Warning: inherited section [Modem0] does not exist in wvdial.conf
-->Initializing modem
-->Sending: ATZ
-->Sending: ATQ0
ATQ0
OK
-->Re-Sending ATZ
ATZ
OK

This block of messages is repeated 2 times and thereafter I am returned to the command prompt.


So nothing's working for me  :cry:

I have Mandrake 9.1 installed on the PC but its Boot Loader is corrupt so in the meantime I want to try the net on the SuSE 9.0 Live Eval.

Help would be greatly appreciated.

Thanks.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #1 on: July 09, 2004, 05:40:48 AM »
This message shows that you have specified wrong port .. change that to ttyS0 to someother port like ttyS1 etc.. and have lil play ..

then tell us..

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #2 on: July 09, 2004, 03:37:35 PM »
Hi,
 I tried to change the port to ttyS1,2,3 etc. by editing wvdial.conf  but it appears that ttys0 is the correct port only because in all the other cases either I got "I/O Error" (mostly this), "Modem not detected" or "Resource Busy".

Ofcourse the install.sh script provided by Reliance gives options of COM1 and COM2 only where I got the same "/var/log/messages not found"  error in both the cases.

What shall I do?

Thanks.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #3 on: July 09, 2004, 04:50:28 PM »
LG has serial port connectivity or USB ..
i think it has serial ..

That wvdial stuff worked when i tried that on samsung n191 , bfore that it was detected as "Samsung CDMA technology" during boot. so it was configured

So can you tell me that ur LG is detected or not ? I am not sure that if it requires to be detected and autoconfigured by OS.
but was that detected ?

Ok one more thing.. have u installed reliance software when you were logged in root ?

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #4 on: July 10, 2004, 05:13:23 AM »
I checked up YaST which is the hardware detection utility in SuSE and it had just the internal modem installed on my PC listed. So I guess the LG phone isn't auto-detected while booting.

But if I run the wvdialconf utility from the command line, it does detect the phone, and it also fills in the wvdial.conf file with some data like modem baud rate, init1 and inti2 strings etc. But on running wvdial after that I get the same results.

Also yes I installed the Reliance software while logged in as root since it wouldn't let it be any other way itself.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #5 on: July 10, 2004, 05:46:32 AM »
wvdialconf is detecting your phone as modem !! then it is fine .. can you post the output of your wvdialconf ?

May be it is initialization string problem. I remember that cdma phone uses diff. init string . To found out which one it is using you can do it by installing reliance software on any M$ computer and then see wht it is automatically get set up in modem string section. put that in wvdial.conf and tell us

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #6 on: July 10, 2004, 06:03:19 AM »
Cool, I will post my wvdialconf output.

You also maybe said that I can see the initialization string in the Reliance software installed under MS Windows. Can you please tell me how do I do this?

Thanks

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #7 on: July 11, 2004, 06:00:27 AM »
Hi,
Here's the output of the wvdialconf command:-

Code: [Select]
Scanning your serial ports for a modem.
Port Scan<*1>: Scanning ttyS0 first, /dev/modem is a link to it. ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try:4800  ttyS0<*1>: ATQ0 V1 E1 -- failed with 4800 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 19200 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 19200 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- OK
ttyS0<*1>: ATQ0 V1 E1 Z -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS0<*1>: Modem Identifier: ATI -- 115200
ttyS0<*1>: Max speed is 115200; that should be safe.
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
Found a modem on /dev/ttyS0, using link /dev/modem in config.
Modem configuration written to wvdial.conf.
ttyS0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

I tried substituting init strings from R-Connect configuration info under Windows as you said to Linux but I am getting the exact same results, except that the first init string is replaced in the wvdial output by whatever I set it as.

Maybe I am not setting them right, all in the correct order.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #8 on: July 11, 2004, 09:28:01 AM »
Quote from: "leenux"
Code: [Select]
Warning: inherited section [Modem0] does not exist in wvdial.conf

Oh man .. I have done a mistake.. just checked my earlier post..
You have to add
Code: [Select]
[Modem0] at the very begining of the config file.. I am using inherit for it but forgot to define it..
sorry..
Try that and tell me.. I have also updated it and now also going to make an proper tutorial for that to be placed in tutotrial and how to section.

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #9 on: July 13, 2004, 07:20:51 AM »
Oh, I had figured out the missing [Modem0] header before and added it myself but it didn't have any effect on the total result. Just that the "Inherited section [Modem0] missing" warning stopped :(.

Cool that you are adding the instructions to setup CDMA phones as modems in the How To and Tutorial section. I'm sure a lot of people would benefit from it :)

Appreciate it.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #10 on: July 13, 2004, 08:07:28 AM »
So its mean it is not yet resolved !! ?

Ummm.. Now I wish that I could get that LG set and hope can check that myself..

BTW.. I have already posted How at Internet using Reliance phone as modem

Offline leenux

  • Linux Noob !
  • *
  • Posts: 7
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #11 on: July 13, 2004, 02:34:17 PM »
heh heh, yeah, it's not installed yet.

I think the software given on Reliance's website would have been much easier and less time consuming if I didn't have the /var/log/messages file missing.

But after all this Linux is just a Live CD, it runs off the CD. Maybe it would be better installing the phone on an installed Linux OS ;)

I got to thank you lots for being patient with my problem :). I did learn a lot in the process. I'm sure if you got your hands on this LG set you would come out with a solution in no time  :P

Thanks for the help ;), I will now try installing the phone on my Mandrake 9.0 (installed) after I repair its LILO bootloader.

Best of luck. Keep up the good work ;)

Oh and saw the tutorial section. It's great *thumbs up*. I love this site *clap-clap*

See you around
Bye.

Offline qmsarge

  • New Member
  • Posts: 1
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #12 on: August 19, 2004, 12:08:47 PM »
Hello All,

My first post out here. Has any body find a way to get the LSP-340E modem work with Linux? I too have a reliance connection with this phone. I run Fedora version of Linux.

1. My Hardware finder was to detect the modem on ttyS4.

2. I have the following wvdial.conf file
[Modem0]
Modem=dev/ttyS4
Baud=230400
Set Volume=0
Dial Command =ATDT
Initl = AT+CRM=1;$LGPKT=3
Flow Control = Hardware (CRTSCTS)
[Dialer cdma]
User Name = my phone
Password = my password
Phone = #777
Stupid Mode = 1
Inherits = Modem0

But when I try to connect, it detects the modem and says the modem is not responding. It tries two times, and then comes back to the prompt. I got the Initialization params, from the modem installed on Windows 2K.

Any fix for this?

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Not able to install Reliance LG phone on SuSE 9.0 Live Eval
« Reply #13 on: August 19, 2004, 12:13:23 PM »
Use reliance software available for linux at their website.. also see this post .. it has everything you wanna know Reliance phone as modem in linux