Network Troublshooting > Linux Servers Support

ftp between computers

(1/2) > >>

A very elementary problem but I cannot solve it after many days.
Two computers. Both in same room. One on my left, one on my right. Both ethernetted to the box on the wall. Both use PCLinux. Both have firewall turned off. I don't give a toss about 'security' I just want them to talk to each other.
I can just about get an ftp connection (on a good day) on Krusader. I want to use this to be able to synchronise the two computers. Both have multiple HD's and multiple partitions by the way. I can type the following on the left:


--and that gets me into my home directory on the right OK. But I don't always want my home directory, but a different partition called, lets say, /media/Slideshows. Much too big to have in my home directory, that's why it has its own partition.

Now there is undoubtedly some easy way to type in some different command that will get me straight into where I want it to be. I can't find simple advice about this anywhere, because it is too elementary (except to me of course). Please someone enlighten me!

Hmmm, sort of the same thought here.  Simple but I don't know if this will work or not.  Do you have a file called .bash_login in the home directory?  Something like this:

--- Code: ---root@fireball / # ls -al /home/dale/.bash_logout
-rw-r--r-- 1 dale users 127 Dec  8  2008 /home/dale/.bash_logout
root@fireball / #
--- End code ---

The contents of my file for a user is this:

--- Code: ---root@fireball / # cat /home/dale/.bash_logout
# /etc/skel/.bash_logout

# This file is sourced when a login shell terminates.

# Clear the screen for security's sake.
root@fireball / #
--- End code ---

All it does is clear the screen.  For my root user:

--- Code: ---root@fireball / # cat /root/.bash_login
setterm -powersave off -blank 0
cd /
root@fireball / #
--- End code ---

On this one, it disabled the powersave since I want to see my screen when compiling in a console.  Long story. 

Since you are using a GUI to do this, I'm not sure it will work.  I would put the following in the file for whatever user you are using and see if it works:

--- Code: ---cd /media/Slideshows

--- End code ---

I'm not sure if the GUI browsers read that file tho.  Just add it to it and see if it works.  If not, just remove it again. 

You may also want to try:

--- Code: ---ftp://myname@192.168.1.xx/media/Slideshows

--- End code ---

Since you are typing that into the GUI, it should see that. 

I gave examples to sort of let you see that the file accepts commands just like you type into a console.

Hope that helps. 

 :)    :) 

Tried the final suggestion:


It just says "could not enter folder /media"

Check the permissions.  That sounds like a permission problem but GUI's are a bit different on those types of errors.  It's been a while since I fired up my 2nd rig so I can't recall the details. I'm also bad to just login as root too.  lol

 :)    :)

Solved it!!!!
I knew it had to be very simple, or other people would have been asking the same.
Here goes.
Configure computer (i.e.Control Center).
Configure ftp.
Go through the several panes and unclick the box that says 'chroot home user'
Then it works. You can ftp into all the other partitions.
Hope this helps someone.
Now my remaining very simple problem - - -
From the left hand computer to the right hand - - it works.
Other way round - - 530 access deny. You have no right to be here!
All the permissions are identical.
Oh well you can't have everything.


[0] Message Index

[#] Next page

Go to full version