September 19, 2018, 08:32:56 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Damaged on Library/Symbolic link etc-Heed Help  (Read 2169 times)

Offline zaxx

  • New Member
  • Posts: 1
Damaged on Library/Symbolic link etc-Heed Help
« on: July 01, 2011, 04:33:32 AM »
Hi, firstly I am not so familiar with linux and i think i have done some damage to the red hat server. It seems that now in command line I am unable to use any basic command whatsoever (ls, move, cp, bash, etc).

I was trying to deploy an application and have changed the symbolic link (soft link?) with the library file. Now I'm unable to even SSH into the server. However, it seems like the GUI works ok, for now.

Could you guys please advise me on how to amend this problem,except for format/recovery as it is impossible for this server.

And a 2nd question, how do i mount a NTFS USB external drive onto Redhat 3.4? Or any commands to mount a FAT32 usb drive? I tried the mount -t /dev/sdb /flash command and it fails.

About the first question, the history was this:-
1292 ls -lrt /lib/tls/libc.so.6
1293 ln -sf /lib/tls/libc.so.6 /usr/lib/libstdc++.so.6
1295 ls -lrt /lib/tls/libc.so.6
1296 ln -sf /usr/lib/libccs.so /lib/tls/libc.so.6
1297 ls -lrt /lib/tls/libc.so.6
1298 ls -lrt /lib/tls/libc.so.6
1308 ln -sf /lib/tls/libc.so.6 libc-2.3.2.so
1309 ln -sf libc-2.3.2.so /lib/tls/libc.so.6-

And now the result is
[root.root@linuxserver01]# ln
ln: /lib/tls/libc.so.6: no version information available (required by ln)
ln: /lib/tls/libc.so.6: no version information available (required by ln)
ln: /lib/tls/libc.so.6: no version information available (required by ln)
ln: /lib/tls/libc.so.6: no version information available (required by ln)
ln: /lib/tls/libc.so.6: no version information available (required by ln)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libc.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libc.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libc.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libc.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /usr/lib/libz.so.1)
ln: /lib/tls/libc.so.6: no version information available (required by /usr/lib/libz.so.1)
ln: /lib/tls/libc.so.6: no version information available (required by /usr/lib/libz.so.1)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libm.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/tls/libm.so.6)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/libgcc_s.so.1)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/libgcc_s.so.1)
ln: /lib/tls/libc.so.6: no version information available (required by /lib/libgcc_s.so.1)
ln: relocation error: /lib/libgcc_s.so.1: symbol __cxa_finalize, version GLIBC_2.1.3 not defined in file libc.so.6 with link time reference

Sorry for the long post and bad english, and thanks in advance
« Last Edit: July 01, 2011, 04:51:59 AM by zaxx »

Offline Avin

  • Linux Learner
  • ***
  • Posts: 54
  • L!nuX
Re: Damaged on Library/Symbolic link etc-Heed Help
« Reply #1 on: August 17, 2011, 05:13:50 AM »
You deleted libarary of GLIBC  package.
try to install glibc rpm package again..  But My opinion reinstall Linux because Glibc is essential package and you will face issue in future if required packages not properly installed.