December 15, 2017, 01:53:51 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: plz help me Mozilla is not workin  (Read 4756 times)

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
plz help me Mozilla is not workin
« on: May 04, 2004, 03:15:00 PM »
Hii all ,

i m usin RedHat 9.0 since last 5 months. today i faced one problem. When i try to open Mozilla it is not opening.  I restarted the machine two times but it is not workin while i open Konqueror Web Browser, it is workin very fine.

plz help me.



puneet :!:  :!:

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
plz help me Mozilla is not workin
« Reply #1 on: May 04, 2004, 03:35:11 PM »
Try to reinstall it.. ie remove mozilla rpm and then reinstall from the installation cd.
do it like.. rpm -e mozilla*.*
then to install from cd.. using add and remove packages or rpm -i mozilla*.*

better log in command line mod to do all , not a shell when X is running

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
some problem to remove
« Reply #2 on: May 05, 2004, 05:50:39 AM »
Hello Ricky,

                       Sorry but can u tell me in detail. coz from add/ remove program when i go there and try to remove it gives error like :-

                      Package not found : The followingh packages could not be found on your system.
                     Installation cannot continue until they are installed.

         unlocatable package                         required by
         
               libgkgfx.so                                    mozilla-dom-inspector
               libgtkembedmoz.so                      kdebindings
               mozilla= 1.2.1-26                          mozilla-mail
               mozilla = 1.2.1-26                         mozilla-psm
               mozilla= 35:1.2.1                          galeon
               mozilla =1.2.1-26                         mozilla-chat
               mozilla =1.2.1-26                         mozilla-devel
               mozilla = 1.2.1-26                        mozilla-dom-inspector
               mozilla = 1.2.1-26                        mozilla-js-debugger
                   mozilla                                       plugger
                                   
                    when i try to remove from  command prompt by givi the command :- rpm -e mozilla the followin error :-
        error: Failed dependencies:
       
        libgkgfx.so is needed by (installed) mozilla-dom-inspector-1.2.1-26
        libgtkembedmoz.so is needed by (installed) kdebindings-3.1-6
        mozilla = 1.2.1-26 is needed by (installed) mozilla-mail-1.2.1-26
        mozilla = 1.2.1-26 is needed by (installed) mozilla-psm-1.2.1-26
        mozilla = 35:1.2.1 is needed by (installed) galeon-1.2.7-3
        mozilla = 1.2.1-26 is needed by (installed) mozilla-chat-1.2.1-26
        mozilla = 1.2.1-26 is needed by (installed) mozilla-devel-1.2.1-26
        mozilla = 1.2.1-26 is needed by (installed) mozilla-dom-inspector-1.2.1-26
        mozilla = 1.2.1-26 is needed by (installed) mozilla-js-debugger-1.2.1-26      
mozilla is needed by (installed) plugger-4.0-23


so plz guide me wat to do from the start. i m very new in this field. should i have to insert the cd when i remove the package frm the add / remove progms.

Offline dragoncity99

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 551
plz help me Mozilla is not workin
« Reply #3 on: May 05, 2004, 10:17:09 AM »
I just face ur problem just now. What i did to solve this problem is:

uninstall the mozilla by typing:

1. rpm -e mozilla-xxxx.i386.rpm --nodeps

2. then reboot

3. enter root and install again by typing:
    rpm -ivh mozilla-xxx.i386.rpm --nodeps from ur cdrom.

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
query for mozill again
« Reply #4 on: May 05, 2004, 10:34:31 AM »
hello dragoncity

but sorry can u tell me in which CD i have mozilla package. and plz tell me , i have to uninstall all the mozilla packages or simply one.


puneet

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
loc of the Mozilla Config file
« Reply #5 on: May 05, 2004, 11:51:57 AM »
hello dragoncity

one more thing plz tell me the exact location of the mozilla file because to remove the packeage we have to enter in the directory. so plz guide me .

puneet

Offline dragoncity99

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 551
plz help me Mozilla is not workin
« Reply #6 on: May 05, 2004, 03:15:43 PM »
Mozilla is located in the 1st CD, this is the path

/mnt/cdrom/RedHat9/RPMS/

find "mozilla-version-i386.rpm" and not something like
"mozilla-mail....rpm"

When u initiate rpm -e mozilla.xxx.i386.rpm, it will delete all the folders and directories. But, PLEASE dont remove any local files in the directories or sth ugly will happen.

Let RPM do all the work.

But at ur own risk. If u want to remove then u may go to /usr/lib/ where u will see 2 mozilla folders. One is "mozilla" itself and another is "mozilla-1.x.x" . If it's not there then it's at /usr/local/

BUT, dont touch this directory if u can. Unless u know what u r doing.

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
still problem
« Reply #7 on: May 06, 2004, 05:08:53 AM »
Hello Dragoncity ,

thnx a lot for bein in touch . but still i m facin problem

when i enter as a root in command prompt after tht when i reinstall the mozilla it gives error like :-

[root@labco root] # rpm -e mozilla

error: Failed dependencies:

libgkgfx.so is needed by (installed) mozilla-dom-inspector-1.2.1-26
libgtkembedmoz.so is needed by (installed) kdebindings-3.1-6
mozilla = 1.2.1-26 is needed by (installed) mozilla-mail-1.2.1-26
mozilla = 1.2.1-26 is needed by (installed) mozilla-psm-1.2.1-26
mozilla = 35:1.2.1 is needed by (installed) galeon-1.2.7-3
mozilla = 1.2.1-26 is needed by (installed) mozilla-chat-1.2.1-26
mozilla = 1.2.1-26 is needed by (installed) mozilla-devel-1.2.1-26
mozilla = 1.2.1-26 is needed by (installed) mozilla-dom-inspector-1.2.1-26
mozilla = 1.2.1-26 is needed by (installed) mozilla-js-debugger-1.2.1-26
mozilla is needed by (installed) plugger-4.0-23

so plz guide me is there any error in givin the command.

puneet    :!:  :!:

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
plz help me Mozilla is not workin
« Reply #8 on: May 06, 2004, 05:50:05 AM »
I was out yesterday...
do this..  
to find exact version of mozialla on ur systemmm..
Code: [Select]
rpm -q mozillaIt will give you some thing like "mozilla-1.4.1-17"
then do following..
Code: [Select]
rpm -e mozilla-1.4.1-17 --nodepsPlease do all above when you are really in command line mode ie. no X should be running anywhere.
Then reboot and again install mozilla from cd but again from command line..
to install from cd .. insert the cd and
Code: [Select]
mount /mnt/cdromthen
Code: [Select]
rpm -ivh mozilla-xxx.i386.rpm --nodeps You should first cd to rpm directory that is..
Code: [Select]
cd /mnt/cdrom/RedHat9/RPMS
What we are doing is reinstall so that if any thing is misconfigured or improper which is not allowing mozilla to run get resolved automatically.

Offline puneetloiya

  • Linux Noob !
  • *
  • Posts: 28
thnx now mozilla is workin
« Reply #9 on: May 06, 2004, 06:45:42 AM »
Hello Ricky and Dragoncity,

thnx a lot . i successfully reinstalled mozilla. now it is workin . thx again

puneet  :lol: