Hardware Troubleshooting in Linux > Linux Audio Support

PCQ Linux 2004 and CM 8738 Problem


I am Sumit . I have installed PCQLinux 2004 on my P-III 700 Mhz, 192 MB RAM , Intel 810 Whitney motherboard with CM 8738 onboard sound. I have Win 98 and Win XP Pro already. I use GRUB boot loader. I have following audio problems:
1. Firstly my linux plays audio CDs fine but when I play .mpg or .avi or any other files there is no sound.
2. When I use soundcard detection in graphical mode (both in KDE and GNOME) it shows
Vendor: C Media Electronics Inc.  
Model:  CM 8738   
Module: cmpci .
But when I play test sound no sound is heard. and an error message pop ups saying "Automatic detection of sound card didn't work, sound will not be available" Even after this Audio Cds r playing finely but not any other files.

3. Then I use "sndconfig" command from console it detects too but when playing test sound, no sound is heard and it doesn't do anything.

4. Also when KDE starts a sound server information msg pop ups saying
" Error while initializing the sound driver device/dev/dsp can't be opened
(Device or resource busy) The sound server will continue using the null output device"

So plz help me in solving this audio problem Thank you! in advance My email: sumits15@rediffmail.com

Do this.. I don't remeber exactly but disable sound on startup.. It is I think in control center in KDE. and then try to reboot and check.. If that don't work..

Try this.. ( although little untechnical but worked for me in almost same case but different soundcard)

Disable your sound card from BIOS and then reboot. Kudzu will ask to keep or remove its driver.. Say remove. then again reboot after complete startup. Now again shutdown .. This time during reboot again enable sound card.. Kudzu will ask .. configure or not.. Say "configure".

And tell us did it worked ?

Lastly you don't need to tell us your email address.. Hope you understand y :)

If that doesn't work, check out the kernel you are using.
uname -r (at the console)
If the kernel is 2.6.x then the system is using kernel level alsa drivers (Advanced Linux sound architecture) and this does not use /dev/dsp.  Try running kernel 2.4.x and then sndconfig should work. Afterwards install atrpms and then do
apt-get install (at the console)
and use it to install synaptic with
apt-get install synaptic (at the console)
Then use synaptic to upgrade your alsa drivers and kernel-module-alsa.
Should work.


[0] Message Index

Go to full version