October 01, 2014, 04:16:11 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Shockwave Flash 10.1 keeps crashing, Ubuntu 10.04, firefox 3.6.6  (Read 10878 times)

Offline hfactor

  • Linux Noob !
  • *
  • Posts: 5
I feel desperate! Ever since I upgraded to Ubuntu 10.04 my SWF mostly will not work!

 A workaround that used to always work, and now sometimes works: I would go to synaptic package manager, install SWF 10.1, then install the SWF 10.1 installer. This would un-install my first installation, but leave my installer installed! I do not understand this, but SWF usually would (after restarting firefox) begin working, until my next startup of the computer, that is! I have to fix it every logon, and sometimes more often.

I also get different results from three sources of test data. "Applications/Ubuntu Software Center" shows I have SWF 10.1 installed. "Synaptic Pkg Manger" also shows I have SWF 10.1, but when I run the Mozilla plugin check, it thinks I have SWF 9.0r48.

When I press the "outdated version" button on the mozilla plugin check page, I go through a routine to update the plugin, but this check page still thinks I have SWF 9.0r48, and none of my flash items like utube work. BTW, I did try to install SWF 10.1, both the APT version, and the tar.gz version to no avail.

The videos never develop, I see a cartoon that looks like a lego toy with a frown face and the words "The Adobe Flash Plugin has Crashed".

Offline hfactor

  • Linux Noob !
  • *
  • Posts: 5
Re: Shockwave Flash 10.1 keeps crashing, Ubuntu 10.04, firefox 3.6.6
« Reply #1 on: July 18, 2010, 03:10:01 AM »
More Info!>>>>>>>>>>>>>>>

Shockwave Flash 10.1 keeps crashing, Ubuntu 10.04, firefox 3.6.6

When I was using Ubuntu 9.10 the flashplugin worked fine. After I upgraded to Ubuntu 10.04 LTS, Youtube and similar movies would play, but in order to get any sound I needed to re-install the flashplugin-installer (version 10.1) after each computer startup. I would use Synaptic package manager. I do not know the location this package is installed.

After a while, even this stopped working. Now all I get is a Leggo-looking frown cartoon and the text "The Adobe Flash plugin has crashed!". Nothing I have tried has fixed this.

According to Synaptic package manager I have no Flash packages installed at this time. Still, in Firefox 3.6.6, when I go to: "tools/add-ons" I see "Shockwave Flash 9.0 r48 and I can Disable or Enable but not remove it.  When I browse to "about:plugins" I get:

***************************************************************************************
Shockwave Flash

    File: /home/madtux/.mozilla/plugins/libflashplayer.so
    Version:
    Shockwave Flash 9.0 r48

MIME Type    Description    Suffixes    Enabled
application/x-shockwave-flash    Shockwave Flash    swf    Yes
application/futuresplash    FutureSplash Player    spl    Yes
 


Shockwave Flash

    File: /usr/lib/mozilla/plugins/libflashplayer.so
    Version:
    Shockwave Flash 9.0 r277

MIME Type    Description    Suffixes    Enabled
application/x-shockwave-flash    Shockwave Flash    swf    Yes
application/futuresplash    FutureSplash Player    spl    Yes
***************************************************************************************

Note that the second entry (Shockwave Flash 9.0 r277) used to contain 10.1, but while following someone elses solution, I reverted to version 9.0 using bash. It did not work!

When I go to: "https://www.mozilla.com/en-US/plugincheck/" the plugin check says I have "Shockwave Flash 9.0 r48", please update. I can follow the update button, and it seems to work. Returning to this page, the plugincheck still thinks I have "Shockwave Flash 9.0 r48" and Flash does not work.

I saw someone's chat for a similar problem on "launchpad", and they suggested that the following output is useful:
(this is my current status)
***************************************************************************************
hyman@madtux-desktop:~$ dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf
rc  libgnash0                                  0.8.0~cvs20070611.1016-1ubuntu3~feisty1              free Flash movie player - shared libraries
rc  mozilla-plugin-gnash                       0.8.7-0ubuntu1                                       free SWF movie player - Plugin for Mozilla a
ii  libswfdec-0.8-0                            0.8.4-1build1                                        SWF (Macromedia Flash) decoder library
ii  pyvnc2swf                                  0.9.5-3                                              screen recording tool with Flash (SWF) outpu
ii  swfmill                                    0.3.0-1                                              xml2swf and swf2xml processor
hyman@madtux-desktop:~$
***************************************************************************************

Note, that if I do an apparently successful upgrade to SWF 10.1 from the mozilla plugincheck web page, the following output:

****************
ii  flashplugin-installer                      10.1.53.64ubuntu0.10.04.3                            Adobe Flash Player plugin installer
****************

is inserted between the "hyman@madtux..." and the "rc  libgnash0 " lines in the copied output, above. Synaptic sees that SWF 10.1 is installed. "Applications/Ubuntu Software Center/Installed Software" sees SWF 10.1 is installed.

>>>>I am confusing myself trying to explain this! Can anybody help?<<<<<

Thanks in advance for any effort expended on this problem!


Offline hfactor

  • Linux Noob !
  • *
  • Posts: 5
Re: Shockwave Flash 10.1 keeps crashing, Ubuntu 10.04, firefox 3.6.6
« Reply #2 on: July 19, 2010, 05:21:00 AM »
 ;D ;D ;D
!!!!!I AM REPORTING SUCCESS!!!!!!!!

After so much reading and trial and error, I discovered Flash Aid!:
 http://flash-aid-extension.blogspot.com/

This worked! Now I'm good!