Linux Software > Linux Installation Support

yum giving problems in fedora 12



M new to linux. Tried 2 instal chrome using yum. Gave the following error.

# yum install google*.rpm

Loaded plugins : presto, packagekit
Setting up install process.....
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/", line 109, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/", line 183, in doCommand
    return base.installPkgs(extcmds)
  File "/usr/share/yum-cli/", line 598, in installPkgs
    if (arg.endswith('.rpm') and (yum.misc.re_remote_url(arg) or
AttributeError: 'module' object has no attribute 're_remote_url'

Same error is produced with any rpm package i try to install.

Pls help.

try runnig command "yum list" , seems that the repo is not created properly. If it gives error  try to create repo again

try below commands
#yum clean all
#yum list

Yes, I agree with gaurav, check your yum repository config file first.

Also, see if your repo is working correctly.
# yum repolist


[0] Message Index

Go to full version