December 15, 2017, 11:34:28 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: ssh problem  (Read 10353 times)

Offline yasir453

  • Linux Noob !
  • *
  • Posts: 5
ssh problem
« on: February 09, 2010, 09:16:11 AM »
hi all
me using redhat on server and open suse on clint.when i want to ssh from my server machine the following error occur
"connection refuse"
i execute the following command on clien machine
"/etc/init.d/sshd start"
it shows the following error just after command execution
"sshd re-exec requires execution with an absolute path"

what can be the solution?

Offline gauravbajaj

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 658
Re: ssh problem
« Reply #1 on: April 20, 2010, 06:33:53 AM »
Which rpm you are using for sshd? It seems that its asking for absolute path , check the /etc/init.d/sshd file and change the sshd path to absolute one

#which sshd
/usr/sbin/sshd

Modify /etc/init.d/sshd and change entry of sshd with above absolute path and try restarting sshd and let me know if it works?

Offline pedro

  • Linux Noob !
  • *
  • Posts: 14
Re: ssh problem
« Reply #2 on: April 20, 2010, 11:00:23 AM »
You need to start the sshd service on the server, not on the client. Once the service is running, you can ssh in from the client.

From the server, as root:
Code: [Select]
/etc/init.d/sshd start
From the client:
Code: [Select]
ssh server-ip
If you then get a connection refused error, it probably means that, either the service is not running (or not properly configured to accept incoming connections) or the firewall running on the server rejects the connection before it reaches the ssh service.

The "sshd re-exec requires execution with an absolute path" error means that "sshd" is not called with an absolute path in the script. You need to replace the sshd with /usr/bin/sshd as gauravbajaj suggested.

Could you post the results of the previous commands? HTH.

Offline getviswa

  • Linux Noob !
  • *
  • Posts: 10
Re: ssh problem
« Reply #3 on: June 02, 2010, 07:24:21 AM »
Disable ur SElinux  /etc/selinux/config