Linux Software > Linux Installation Support

Unable to boot GRUB Bootloader (menu): boots straight into GRUB command shell


Hi - I have a (serious) problem, and help very greatly appreciated.
A failed upgrade, from disk images, of Fedora 10 to 11 resulted in no GRUB bootloader main menu appearing on bootup (no WIN, no LINUX choices from which to boot). I am booted directly into the GRUB command, no WIN, no LINUX, nothing. And my understanding of GRUB shell commands is very low.
I have 2 hard disks, WIN on the first, LINUX on the second. I believe GRUB Bootloader is on the first disk.
Sadly, I have no external install media.
An old grub.conf hardcopy indicates that root =/dev/sdb2, root (hd1,0), kernel /vmlinuz....olderversion...(relative to /boot),
initrd /initrd...olderversion... (relative to boot).
and WINDOWS on (hd0,1), with chainloader +1

I need to somehow get past this grub shell, and re-install/re-instate the grub bootloader, so it can boot normally.
What grub command(s) must I use? I've played around with the commands, but with no success.
I worry that if I can't resolve this, the whole machine may be useless.
I pray someone can help me here.
George :-[


It looks like that boot loader got correputed while doing the upgrade. Try to fic it using rescue mode:

boot from Linux CD , & boot prompt give
#boot:linux rescue

After asking some questions to you ,it will automatically goes to command prompt
At the command prompt, give this command :
#chroot /mnt/sysimage
# grub install /dev/sdx { if its scsi, change x with the disk type means wheather its a or b etc, if the disk is IDE then change to hda or hdb)

After that reboot ur System........

Thanks guarav
Various grub commands to find vmlinux, initrd so that I gcould define root, kernle, initrd and then boot etc all failed, indicating to me that the failed upgrade partitioned/formatted the LINUX HD, which is now useless. I can live with that.
I tried to reboot from an old Fedora DVD but got kbrd errors...strike F1 for ...something...F2 for setup...both failed....

I agree that the grub bootloader (on WIN DISK 1) was corrupted, and wish to re-instate the MBR (in WIN, to re-instate the WIN MBR, and invoke NT Bootloader. Frome there perhaps I can proceed to re0install LINUX). So getting WIN back is the priority. I understand there are commands to do this, but have no floppy rescue disk. Am trying to get a friend to make on. Using a laptop at work, which has no floppy!!!
Is a very bad situation.

yeah its bad situation  :( .If Linux is correputed then I belive you can make the WIN Loader back by using the win bootable CD (try to arrange from your friend if you dont have it ).

I think you already know the below commands but still I am writing the below one:

Boot from Windows bootable CD and go to windows console mode and then  "fixmbr" and "fixboot" commands would reinitate/reinstall the win boot loader.

If this also doesnt work then there is no chose other then to re-install the OS  :(

I tried booting from the original WIN installation CD that came from DELL with the machine, but nothing happens (I changed the BIOS boot order).
It just gets worse...


[0] Message Index

Go to full version