November 26, 2014, 07:42:16 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: HOW TO INSTALL RPM OF VLC  (Read 2120 times)

Offline bipinsingh0

  • New Member
  • Posts: 2
HOW TO INSTALL RPM OF VLC
« on: August 08, 2009, 03:22:37 AM »
HI EVERY ONE
  I AM NEW TO LINUX , I WANT TO INSTALL RPM PACKAGE OF VLC IN LINUX , BUT IT IS GIVING DEPENDENCY ERROR PLEASE
HELP ME

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: HOW TO INSTALL RPM OF VLC
« Reply #1 on: August 09, 2009, 12:08:47 PM »
Can you post here what errors you saw ?

Offline bipinsingh0

  • New Member
  • Posts: 2
Re: HOW TO INSTALL RPM OF VLC
« Reply #2 on: August 09, 2009, 12:51:15 PM »
i install as -
[root@bipin bipin]# rpm -i vlc-0.9.9-2.el5.rf.i386.rpm
error: Failed dependencies:
        libSDL_image-1.2.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        liba52.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libaa.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libavcodec.so.51 is needed by vlc-0.9.9-2.el5.rf.i386
        libavformat.so.51 is needed by vlc-0.9.9-2.el5.rf.i386
        libavutil.so.49 is needed by vlc-0.9.9-2.el5.rf.i386
        libcaca.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libcddb.so.2 is needed by vlc-0.9.9-2.el5.rf.i386
        libcucul.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libcv.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libcvaux.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libcxcore.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libdca.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libdirac_decoder.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libdirac_encoder.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libdvbpsi.so.4 is needed by vlc-0.9.9-2.el5.rf.i386
        libdvdnav.so.4 is needed by vlc-0.9.9-2.el5.rf.i386
        libdvdread.so.3 is needed by vlc-0.9.9-2.el5.rf.i386
        libebml.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libfaac.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libfaad.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libfribidi.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libgsm.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libhighgui.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libid3tag.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libixml.so.2 is needed by vlc-0.9.9-2.el5.rf.i386
        liblirc_client.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libmad.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libmatroska.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libml.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libmodplug.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libmp3lame.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libmpcdec.so.5 is needed by vlc-0.9.9-2.el5.rf.i386
        libmpeg2.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libpostproc.so.51 is needed by vlc-0.9.9-2.el5.rf.i386
        libshout.so.3 is needed by vlc-0.9.9-2.el5.rf.i386
        libtag.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libtwolame.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
        libupnp.so.3 is needed by vlc-0.9.9-2.el5.rf.i386
        libvga.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libvgagl.so.1 is needed by vlc-0.9.9-2.el5.rf.i386
        libx264.so.55 is needed by vlc-0.9.9-2.el5.rf.i386
        libxosd.so.2 is needed by vlc-0.9.9-2.el5.rf.i386
        libxvidcore.so.4 is needed by vlc-0.9.9-2.el5.rf.i386
        libzvbi.so.0 is needed by vlc-0.9.9-2.el5.rf.i386
---------------------------------------------------------------------------------
if i install as -
[root@bipin bipin]# yum vlc-0.9.9-2.el5.rf.i386
Loading "security" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, list-security, provides, shell, install, whatprovides, groupinstall, update, repolist, groupupdate, info, search, check-update, list-sec, list, remove, info-sec, clean, info-security, grouperase >

options:
  -h, --help            show this help message and exit
  -t, --tolerant        be tolerant of errors
  -C                    run entirely from cache, don't update cache
  -c  [config file]     config file location
  -R  [minutes]         maximum command wait time
  -d  [debug level]     debugging output level
  -e  [error level]     error output level
  -q, --quiet           quiet operation
  -v, --verbose         verbose operation
  -y                    answer yes for all questions
  --version             show Yum version and exit
  --installroot=[path]  set install root
  --enablerepo=[repo]   enable one or more repositories (wildcards allowed)
  --disablerepo=[repo]  disable one or more repositories (wildcards allowed)
  -x [package], --exclude=[package]
                        exclude package(s) by name or glob
  --disableexcludes=[repo]
                        disable exclude from main, for a repo or for
                        everything
  --obsoletes           enable obsoletes processing during updates
  --noplugins           disable Yum plugins
  --nogpgcheck          disable gpg signature checking
  --disableplugin=[plugin]
                        disable plugins by name
  --security            Include security relevant packages
  --cve=CVE             Include packages needed to fix the given CVE
  --bz=BZ               Include packages needed to fix the given BZ
  --advisory=ADVISORY   Include packages needed to fix the given advisory
[root@bipin bipin]# yum vlc-0.9.9-2.el5.rf.i386.rpm
Loading "security" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, list-security, provides, shell, install, whatprovides, groupinstall, update, repolist, groupupdate, info, search, check-update, list-sec, list, remove, info-sec, clean, info-security, grouperase >

options:
  -h, --help            show this help message and exit
  -t, --tolerant        be tolerant of errors
  -C                    run entirely from cache, don't update cache
  -c  [config file]     config file location
  -R  [minutes]         maximum command wait time
  -d  [debug level]     debugging output level
  -e  [error level]     error output level
  -q, --quiet           quiet operation
  -v, --verbose         verbose operation
  -y                    answer yes for all questions
  --version             show Yum version and exit
  --installroot=[path]  set install root
  --enablerepo=[repo]   enable one or more repositories (wildcards allowed)
  --disablerepo=[repo]  disable one or more repositories (wildcards allowed)
  -x [package], --exclude=[package]
                        exclude package(s) by name or glob
  --disableexcludes=[repo]
                        disable exclude from main, for a repo or for
                        everything
  --obsoletes           enable obsoletes processing during updates
  --noplugins           disable Yum plugins
  --nogpgcheck          disable gpg signature checking
  --disableplugin=[plugin]
                        disable plugins by name
  --security            Include security relevant packages
  --cve=CVE             Include packages needed to fix the given CVE
  --bz=BZ               Include packages needed to fix the given BZ
  --advisory=ADVISORY   Include packages needed to fix the given advisory


Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: HOW TO INSTALL RPM OF VLC
« Reply #3 on: August 11, 2009, 09:56:28 AM »
Try this :

Code: [Select]
yum install vlc*

Offline neerp2000

  • Linux Noob !
  • *
  • Posts: 4
Re: HOW TO INSTALL RPM OF VLC
« Reply #4 on: January 09, 2010, 07:36:24 AM »
open vi /etc/yum.repos.d/abc.repo
put these line into abc.repo file
[linux-i386]
name=Systems Incorporated
baseurl=http://apt.sw.be/redhat/el5/en/i386/rpmforge/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY

and also use GPG key paste this key into
vi /etc/pki/rpm-gpg/RPM-GPG-KEY

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.2.1 (GNU/Linux)

mQGiBD9JMT0RBAC9Q2B0AloUMTxaK73sD0cOu1MMdD8yuDagbMlDtUYA1aGeJVO6
TV02JLGr67OBY+UkYuC1c3PUwmb3+jakZd5bW1L8E2L705wS0129xQOZPz6J+alF
5rTzVkiefg8ch1yEcMayK20NdyOmhDGXQXNQS8OJFLTIC6bJs+7MZL83/wCg3cG3
3q7MWHm3IpJb+6QKpB9YH58D/2WjPDK+7YIky/JbFBT4JPgTSBy611+bLqHA6PXq
39tzY6un8KDznAMNtm+NAsr6FEG8PHe406+tbgd7tBkecz3HPX8nR5v0JtDT+gzN
8fM3kAiAzjCHUAFWVAMAZLr5TXuoq4lGTTxvZbwTjZfyjCm7gIieCu8+qnPWh6hm
30NgA/0ZyEHG6I4rOWqPks4vZuD+wlp5XL8moBXEKfEVOMh2MCNDRGnvVHu1P3eD
oHOooVMt9sWrGcgxpYuupPNL4Uf6B6smiLlH6D4tEg+qCxC17zABI5572XJTJ170
JklZJrPGtnkPrrKMamnN9MU4RjGmjh9JZPa7rKjZHyWP/z/CBrQ1RGFnIFdpZWVy
cyAoRGFnIEFwdCBSZXBvc2l0b3J5IHYxLjApIDxkYWdAd2llZXJzLmNvbT6IWQQT
EQIAGQUCP0kxPQQLBwMCAxUCAwMWAgECHgECF4AACgkQog5SFGuNeeYvDQCeKHST
hIq/WzFBXtJOnQkJGSqAoHoAnRtsJVWYmzYKHqzkRx1qAzL18Sd0iEYEEBECAAYF
Aj9JMWAACgkQoj2iXPqnmevnOACfRQaageMcESHVE1+RSuP3txPUvoEAoJAtOHon
g+3SzVNSZLn/g7/Ljfw+uQENBD9JMT8QBACj1QzRptL6hbpWl5DdQ2T+3ekEjJGt
llCwt4Mwt/yOHDhzLe8SzUNyYxTXUL4TPfFvVW9/j8WOkNGvffbs7g84k7a5h/+l
IJTTlP9V9NruDt1dlrBe+mWF6eCY55OFHjb6nOIkcJwKxRd3nGlWnLsz0ce9Hjrg
6lMrn0lPsMV6swADBQP9H42sss6mlqnJEFA97Fl3V9s+7UVJoAIA5uSVXxEOwVoh
Vq7uECQRvWzif6tzOY+vHkUxOBRvD6oIU6tlmuG3WByKyA1d0MTqMr3eWieSYf/L
n5VA9NuD7NwjFA1kLkoDwfSbsF51LppTMkUggzwgvwE46MB6yyuqAVI1kReAWw+I
RgQYEQIABgUCP0kxPwAKCRCiDlIUa4155oktAKDAzm9QYbDpk6SrQhkSFy016BjE
BACeJU1hpElFnUZCL4yKj4EuLnlo8kc=
=mqUt
-----END PGP PUBLIC KEY BLOCK-----


after that restart yum service and check that repository is working or not
if its working run
yum -y install vlc*