December 18, 2017, 03:10:09 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Connecting CDMA (tata indicom) using serial cable for internet  (Read 3967 times)

Offline akashyak

  • Tux Awared
  • **
  • Posts: 44
Hello Ricky,

This has reference to my earlier entry - the just-before-this entry regarding Tata Indicom phone.

The phone modem malfunctions, and the USB cable is not working. So ttyACM0 disappeared from /dev directory. The engineers from Tata Indicom tested that a serial cable is of good use with the same phone piece, and it worked in Windows XP.

Could you therefore tell me how I can make use of this new cable in Linux as well? I can't connect to Internet using "sudo wvdial tata" command. What changes could I make to my /etc/wvdial.conf, which is currently as below:

(start)
---------------------------------------------------------
[dialer defaults]
Init1 = ATZ
Init2 = AT+CRM = 1
ISDN = 0
Modem = /dev/ttyACM0
Baud = 460800
Flow control = Hardware (CRTSCTS)
Carrier check = no
Dial command = ATDT
SetVolume = 0

[Dialer tata]
Phone = #777
Username = internet
Password = internet

Stupid Mode = 1
-------------------------------------------------------
(end)

Thank you.
Akash.
« Last Edit: June 03, 2007, 05:18:37 PM by Ricky »

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #1 on: June 03, 2007, 05:26:12 PM »
Please use appropriate title for the question, it makes it easy to answer.

Its simple,
Change :
Modem = /dev/ttyACM0

To
Modem=/dev/input/ttyS0

If it doesn't work then re-run wvdialconf and shall tell you that on which port it found your modem.

Offline akashyak

  • Tux Awared
  • **
  • Posts: 44
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #2 on: July 02, 2007, 10:02:25 AM »
Well it took me so many days to buy a serial cable, I'm sorry, but the USB cable was still working well in Linux although not in XP. They changed the phone piece, and again USB troubles me. So I went in for serial cable.

As you told me, Ricky, I ran sudo wvdialconf /etc/wvdial.conf and got this:

(begin)
****************************
akash@akash-desktop:~$ sudo wvdialconf /etc/wvdial.conf
Password:
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttySL0<*1>: ATQ0 V1 E1 -- OK
ttySL0<*1>: ATQ0 V1 E1 Z -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySL0<*1>: Modem Identifier: ATI -- SmartLink Soft Modem
ttySL0<*1>: Speed 4800: AT -- OK
ttySL0<*1>: Speed 9600: AT -- OK
ttySL0<*1>: Speed 19200: AT -- OK
ttySL0<*1>: Speed 38400: AT -- OK
ttySL0<*1>: Speed 57600: AT -- OK
ttySL0<*1>: Speed 115200: AT -- OK
ttySL0<*1>: Speed 230400: AT -- OK
ttySL0<*1>: Speed 460800: AT -- OK
ttySL0<*1>: Max speed is 460800; that should be safe.
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySL0.
Modem configuration written to /etc/wvdial.conf.
ttySL0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

*****************************
(end)

So what can I do now? It looks like my serial cable is not being detected at all. There's no ttyS0 in /dev/input

Kindly note that the PC-end of the cable has a serial interface, while the phone-end has, I think, USB interface.. just like the phone-end of my earlier USB cable had.

Regards,
Akash.
« Last Edit: July 02, 2007, 10:28:40 AM by akashyak »

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #3 on: July 03, 2007, 12:07:59 PM »
May I know which phone you have from TATA ?

Offline akashyak

  • Tux Awared
  • **
  • Posts: 44
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #4 on: July 05, 2007, 06:59:25 AM »
LSP 350T

Got it, by the way. All I had to do was to set my phone's Data Baud from USB to 115200. Then I ran wvdialconf, and my phone was recognized on ttyS0. And not /dev/input/ttyS0.

With thanks in advance,
Akash.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #5 on: July 05, 2007, 04:46:48 PM »
I am glad it worked and it was the reason I was asking for the phone model!

Offline akashyak

  • Tux Awared
  • **
  • Posts: 44
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #6 on: July 08, 2007, 03:08:59 PM »
By the way, can I have two options in a single "wvdial.conf" ? I mean to say, can I incorporate both Tata Indicom as well as Sancharnet (or NetOne) from Bsnl?

So that I can dial my choice and others can be told to dial BSNL alone?

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #7 on: July 08, 2007, 06:27:27 PM »
Ya it is very possible..

Taking your provided file as example :
Code: [Select]
[dialer defaults]
Init1 = ATZ
Init2 = AT+CRM = 1
ISDN = 0
Modem = /dev/ttyACM0
Baud = 460800
Flow control = Hardware (CRTSCTS)
Carrier check = no
Dial command = ATDT
SetVolume = 0

[Dialer tata]
Phone = #777
Username = internet
Password = internet

[Dialer Sancharnet]
<fill this place with the features ,
options specific to your normal dialup modem>

Now whenver you connect then type:
Code: [Select]
wvdial sancharnet to connect to sancharnet

Code: [Select]
wvdial tatafor tata

and if you do only wvdial then it will take default options in account !

Offline akashyak

  • Tux Awared
  • **
  • Posts: 44
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #8 on: July 09, 2007, 01:41:28 PM »
Yeah it's working. Thank you.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Re: Connecting CDMA (tata indicom) using serial cable for internet
« Reply #9 on: July 09, 2007, 04:20:20 PM »
I am glad it worked for you !