November 23, 2014, 09:38:19 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Automatic shutdown  (Read 3680 times)

Offline kenchix1

  • Tux Awared
  • **
  • Posts: 37
Automatic shutdown
« on: March 18, 2004, 11:07:14 AM »
I'm confused why my IBM xseries 220 doesn't automatically shutdown whenever I typed "Poweroff" or "Shutdown -h now". It just says at the end "Power Down." and I have to press the power button manually to turn of the computer. Is there any file that i can alter to make the automatic shutdown work ?

BTW, I installed linux on another computer and it automatically power off itself just by typing "poweroff".

Please help.
Thanks in advance.

Offline neo

  • Linux Learner
  • ***
  • Posts: 125
    • http://www.investorsgain.com
Automatic shutdown
« Reply #1 on: March 18, 2004, 01:32:07 PM »
ya man i also faced the same thing so i started shutting down from the GUI or started using telinit 0

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Automatic shutdown
« Reply #2 on: March 18, 2004, 02:24:42 PM »
Well i have never faced such thing but seems to be that your Linux is treating your box as AT not atx..
btw.. init 0 will shutdwn ur computer but it runs only as root..
Did u tired
Code: [Select]
halt -p

Offline aaa

  • Tux Awared
  • **
  • Posts: 38
Automatic shutdown
« Reply #3 on: March 18, 2004, 04:31:50 PM »
Which Linux is this? The auto-poweroff is enabled by enabling the APM or ACPI power management.

Offline kenchix1

  • Tux Awared
  • **
  • Posts: 37
Automatic shutdown
« Reply #4 on: March 19, 2004, 08:01:52 AM »
halt -p didn't power off the machine. just like "poweroff"

what's APM and ACPI ?

Offline aaa

  • Tux Awared
  • **
  • Posts: 38
Automatic shutdown
« Reply #5 on: March 19, 2004, 01:37:32 PM »
They are power management systems.
What happens when you run (as root)
apmd
ls /proc/acpi

Offline kenchix1

  • Tux Awared
  • **
  • Posts: 37
Automatic shutdown
« Reply #6 on: March 20, 2004, 01:39:42 AM »
when i run apmd it says
No APM support in kernel

ls /proc/acpi
No such directory

Offline aaa

  • Tux Awared
  • **
  • Posts: 38
Automatic shutdown
« Reply #7 on: March 22, 2004, 09:03:34 PM »
What distro are you using? Sometimes the power management can be enabled easily. Otherwise, you will need to recompile your kernel. When recompiling, first leave out acpi support and see if apm works. Then try acpi.