September 19, 2014, 11:48:13 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: problems with the configuration of Xfree86  (Read 3694 times)

Offline Hamidreza

  • New Member
  • Posts: 3
problems with the configuration of Xfree86
« on: November 09, 2003, 04:16:51 PM »
I have trouble configuring Xfree86 using xf86config program.
my Linux distribution is Debian ver 3.0 (i386) with Xfree86 ver 4.1. and my video card is Matrox millennium G550 which is not in the list
which xf86config shows, so i choose a very close video card: Matrox Millennium G400. this should work but it dosen't. there is no
problem with the rest of  the configuration process. when I start Xfree86 (using startx), the output is:


warning: process set to nice value 0 instead of -10 as requested

This is a pre-release version of XFree86, and is not supported in any
way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
   If the server is older than 6-12 months, or if your card is
   newer than the above date, look for a newer version before
   reporting problems.  (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.4.17 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Nov  9 12:49:06 2003
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "My Monitor"
(**) |   |-->Device "Matrox Millennium G400"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc105"
(**) XKB: layout: "us"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:
unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/
X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 0.1.0
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(--) PCI:*(1:0:0) Matrox unknown chipset (0x2527) rev 1, Mem @ 0xdc000000/25, 0xdfefc000/14, 0xdf000000/23, BIOS @ 0xdfec0000/17
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.1.9
(II) Loading /usr/X11R6/lib/modules/drivers/mga_drv.o
(II) Module mga: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.1
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
   compiled for 4.1.0.1, module version = 1.0.0
(II) MGA: driver for Matrox chipsets: mga2064w, mga1064sg, mga2164w,
   mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI, mgag400
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.

X connection to :0.0 broken (explicit kill or server shutdown).



Here is the Screen section of the file XF86Config :










Section "Screen"
    Identifier  "Screen 1"
    Device      "Matrox Millennium G400"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "640x480" "800x600" "1024x768" "1280x1024"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "640x480" "800x600" "1024x768" "1280x1024"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "640x480" "800x600" "1024x768" "1280x1024"
        ViewPort    0 0
    EndSubsection
EndSection



and finally the output of the command: cat /proc/pci   is


PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: VIA Technologies Unknown device (rev 0).
      Vendor id=1106. Device id=3189.
      Medium devsel.  Master Capable.  Latency=8.  
      Prefetchable 32 bit memory at 0xe0000000 [0xe0000008].
  Bus  0, device   1, function  0:
    PCI bridge: VIA Technologies Unknown device (rev 0).
      Vendor id=1106. Device id=b168.
      Medium devsel.  Master Capable.  No bursts.  Min Gnt=12.
  Bus  0, device  11, function  0:
    Communication controller: Unknown vendor Unknown device (rev 8).
      Vendor id=14f1. Device id=1056.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  Latency=32.  
      Non-prefetchable 32 bit memory at 0xdfff0000 [0xdfff0000].
      I/O at 0xec00 [0xec01].
  Bus  0, device  16, function  2:
    USB Controller: VIA Technologies VT 82C586 Apollo USB (rev 128).
      Medium devsel.  IRQ 10.  Master Capable.  Latency=32.  
      I/O at 0xe800 [0xe801].
  Bus  0, device  16, function  1:
    USB Controller: VIA Technologies VT 82C586 Apollo USB (rev 128).
      Medium devsel.  IRQ 10.  Master Capable.  Latency=32.  
      I/O at 0xe400 [0xe401].
  Bus  0, device  16, function  0:
    USB Controller: VIA Technologies VT 82C586 Apollo USB (rev 128).
      Medium devsel.  IRQ 11.  Master Capable.  Latency=32.  
      I/O at 0xe000 [0xe001].
  Bus  0, device  16, function  3:
    USB Controller: VIA Technologies Unknown device (rev 130).
      Vendor id=1106. Device id=3104.
      Medium devsel.  IRQ 10.  Master Capable.  Latency=32.  
      Non-prefetchable 32 bit memory at 0xdffeff00 [0xdffeff00].
  Bus  0, device  17, function  0:
    ISA bridge: VIA Technologies Unknown device (rev 0).
      Vendor id=1106. Device id=3177.
      Medium devsel.  Master Capable.  No bursts.  
  Bus  0, device  17, function  1:
    IDE interface: VIA Technologies VT 82C586 Apollo IDE (rev 6).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=32.  
      I/O at 0xfc00 [0xfc01].
  Bus  0, device  17, function  5:
    Multimedia audio controller: VIA Technologies Unknown device (rev 80).
      Vendor id=1106. Device id=3059.
      Medium devsel.  IRQ 10.  
      I/O at 0xdc00 [0xdc01].
  Bus  1, device   0, function  0:
    VGA compatible controller: Matrox Unknown device (rev 1).
      Vendor id=102b. Device id=2527.
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master Capable.  Latency=32.  Min Gnt=16.Max Lat=32.
      Prefetchable 32 bit memory at 0xdc000000 [0xdc000008].
      Non-prefetchable 32 bit memory at 0xdfefc000 [0xdfefc000].
      Non-prefetchable 32 bit memory at 0xdf000000 [0xdf000000].



and one thing more, I downloaded the latest drivers for my card from the internet (manufac. website) and I used the installation script provided.
so there is new driver installed in  /usr/X11R6/lib/modules/drivers
but the problem is that I do not know how to have Xfree86 use the newly installed drivers !!  :roll:

Thank you very much for your kind support.

Offline Hamidreza

  • New Member
  • Posts: 3
Foolish mistakes again !!
« Reply #1 on: November 10, 2003, 04:54:47 PM »
I think I solved the problem  :o
There was a peculiar problem with Matrox driver installation script, finishing the job it indicates successful installation but in fact it doesn't copy a single file !! I was fortunate enough to notice that. so I did it manually and it worked.

I'm very sorry if I've wasted anyone's time  :lol:

by the way the driver package version is 2.00.

Offline Hacker

  • Linux Noob !
  • *
  • Posts: 6
problems with the configuration of Xfree86
« Reply #2 on: November 22, 2003, 05:13:58 AM »
well thats ok. Dont beleive you have wasted anyones time. At least we came to know about one more new stuff which none of us would ahev seen if it was not for you. thankx for that.

Offline mac

  • New Member
  • Posts: 1
problems with the configuration of Xfree86
« Reply #3 on: January 18, 2004, 12:42:50 PM »
I have a problem with my X too.

Here is the log ;(

XFree86 Version 4.3.0 (Debian 4.3.0-0ds4 20030416150820 dstone@aedificator)
Release Date: 18 March 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-pre5 i686 [ELF]
Build Date: 16 April 2003
   Before reporting problems, check http://www.XFree86.Org/
   to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.21-xfs (root@omega) (gcc version 3.2.3 (Debian)) #13 SMP Tue Aug 26 01:46:14 CEST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Jan 18 04:23:37 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "es"
(**) XKB: layout: "es"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "PS/2 Mouse"
(**) |-->Input Device "USB Mouse"
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/75dpi".
   Entry deleted from font path.
   (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/75dpi").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/75dpi".
   Entry deleted from font path.
   (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/75dpi").
(WW) The directory "/usr/X11R6/lib/X11/fonts/PEX" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/ttf/western" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/ttf/decoratives" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/truetype/openoffice" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/defoma/CID" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/defoma/TrueType" does not exist.
   Entry deleted from font path.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/Type1"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail" "true"
(++) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
   XFree86 ANSI C Emulation: 0.2
   XFree86 Video Driver: 0.6
   XFree86 XInput driver : 0.4
   XFree86 Server Extension : 0.2
   XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000070, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1039,0651 card 1039,0651 rev 02 class 06,00,00 hdr 80
(II) PCI: 00:01:0: chip 1039,0001 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:02:0: chip 1039,0008 card 0000,0000 rev 25 class 06,01,00 hdr 80
(II) PCI: 00:02:5: chip 1039,5513 card 1039,5513 rev 00 class 01,01,80 hdr 00
(II) PCI: 00:02:7: chip 1039,7012 card 1458,a002 rev a0 class 04,01,00 hdr 00
(II) PCI: 00:03:0: chip 1039,7001 card 1039,7001 rev 0f class 0c,03,10 hdr 80
(II) PCI: 00:03:1: chip 1039,7001 card 1039,7001 rev 0f class 0c,03,10 hdr 00
(II) PCI: 00:03:3: chip 1039,7002 card 1458,5004 rev 00 class 0c,03,20 hdr 00
(II) PCI: 00:09:0: chip 1045,c861 card 1045,c861 rev 10 class 0c,03,10 hdr 00
(II) PCI: 00:0a:0: chip 10ec,8139 card 10ec,8139 rev 10 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 1039,6325 card 1039,6325 rev 00 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
   
  • -1   0   0x00000000 - 0x0000ffff (0x10000) IX

(II) Bus 0 non-prefetchable memory range:
   
  • -1   0   0x00000000 - 0xffffffff (0x0) MX

(II) Bus 0 prefetchable memory range:
   
  • -1   0   0x00000000 - 0xffffffff (0x0) MX

(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000e (VGA_EN is set)
(II) Bus 1 I/O range:
   
  • -1   0   0x0000c000 - 0x0000c0ff (0x100) IX
  • [1] -1   0   0x0000c400 - 0x0000c4ff (0x100) IX

   [2] -1   0   0x0000c800 - 0x0000c8ff (0x100) IX
   [3] -1   0   0x0000cc00 - 0x0000ccff (0x100) IX
(II) Bus 1 non-prefetchable memory range:
   
  • -1   0   0xec000000 - 0xec0fffff (0x100000) MX

(II) Bus 1 prefetchable memory range:
   
  • -1   0   0xe0000000 - 0xe7ffffff (0x8000000) MX

(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:2:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) Silicon Integrated Systems [SiS] SiS650/651/M650/740 PCI/AGP VGA Display Adapter rev 0, Mem @ 0xe0000000/27, 0xec000000/17, I/O @ 0xc000/7
(II) Addressable bus resource ranges are
   
  • -1   0   0x00000000 - 0xffffffff (0x0) MX
  • [1] -1   0   0x00000000 - 0x0000ffff (0x10000) IX

(II) OS-reported resource ranges:
   
  • -1   0   0xffe00000 - 0xffffffff (0x200000) MX(B)
  • [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX
E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
   [5] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
   [6] -1   0   0x00000000 - 0x000000ff (0x100) IX
(II) PCI Memory resource overlap reduced 0xe8000000 from 0xebffffff to 0xe7ffffff
(II) Active PCI resource ranges:
   
  • -1   0   0xec104000 - 0xec1040ff (0x100) MX
  • [1] -1   0   0xec103000 - 0xec103fff (0x1000) MX

   [2] -1   0   0xec102000 - 0xec102fff (0x1000) MX
   [3] -1   0   0xec101000 - 0xec101fff (0x1000) MX
   [4] -1   0   0xec100000 - 0xec100fff (0x1000) MX
   [5] -1   0   0xe8000000 - 0xe7ffffff (0x0) MXO
   [6] -1   0   0xec000000 - 0xec01ffff (0x20000) MX(B)
   [7] -1   0   0xe0000000 - 0xe7ffffff (0x8000000) MX(B)
   [8] -1   0   0x0000e000 - 0x0000e0ff (0x100) IX
   [9] -1   0   0x0000dc00 - 0x0000dc7f (0x80) IX
   [10] -1   0   0x0000d800 - 0x0000d8ff (0x100) IX
   [11] -1   0   0x0000f000 - 0x0000f00f (0x10) IX
   [12] -1   0   0x0000c000 - 0x0000c07f (0x80) IX(B)
(II) Active PCI resource ranges after removing overlaps:
   
  • -1   0   0xec104000 - 0xec1040ff (0x100) MX
  • [1] -1   0   0xec103000 - 0xec103fff (0x1000) MX

   [2] -1   0   0xec102000 - 0xec102fff (0x1000) MX
   [3] -1   0   0xec101000 - 0xec101fff (0x1000) MX
   [4] -1   0   0xec100000 - 0xec100fff (0x1000) MX
   [5] -1   0   0xe8000000 - 0xe7ffffff (0x0) MXO
   [6] -1   0   0xec000000 - 0xec01ffff (0x20000) MX(B)
   [7] -1   0   0xe0000000 - 0xe7ffffff (0x8000000) MX(B)
   [8] -1   0   0x0000e000 - 0x0000e0ff (0x100) IX
   [9] -1   0   0x0000dc00 - 0x0000dc7f (0x80) IX
   [10] -1   0   0x0000d800 - 0x0000d8ff (0x100) IX
   [11] -1   0   0x0000f000 - 0x0000f00f (0x10) IX
   [12] -1   0   0x0000c000 - 0x0000c07f (0x80) IX(B)
(II) OS-reported resource ranges after removing overlaps with PCI:
   
  • -1   0   0xffe00000 - 0xffffffff (0x200000) MX(B)
  • [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX
E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
   [5] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
   [6] -1   0   0x00000000 - 0x000000ff (0x100) IX
(II) All system resource ranges:
   
  • -1   0   0xffe00000 - 0xffffffff (0x200000) MX(B)
  • [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX
E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX
   [5] -1   0   0xec104000 - 0xec1040ff (0x100) MX
   [6] -1   0   0xec103000 - 0xec103fff (0x1000) MX
   [7] -1   0   0xec102000 - 0xec102fff (0x1000) MX
   [8] -1   0   0xec101000 - 0xec101fff (0x1000) MX
   [9] -1   0   0xec100000 - 0xec100fff (0x1000) MX
   [10] -1   0   0xe8000000 - 0xe7ffffff (0x0) MXO
   [11] -1   0   0xec000000 - 0xec01ffff (0x20000) MX(B)
   [12] -1   0   0xe0000000 - 0xe7ffffff (0x8000000) MX(B)
   [13] -1   0   0x0000ffff - 0x0000ffff (0x1) IX
   [14] -1   0   0x00000000 - 0x000000ff (0x100) IX
   [15] -1   0   0x0000e000 - 0x0000e0ff (0x100) IX
   [16] -1   0   0x0000dc00 - 0x0000dc7f (0x80) IX
   [17] -1   0   0x0000d800 - 0x0000d8ff (0x100) IX
   [18] -1   0   0x0000f000 - 0x0000f00f (0x10) IX
   [19] -1   0   0x0000c000 - 0x0000c07f (0x80) IX(B)
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Server Extension, version 0.2
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Server Extension
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Server Extension
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o":  No symbols found
(II) Module speedo: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.1
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.2
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 2.0.2
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.13.0
   Module class: XFree86 Server Extension
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "fbdev"
(II) Loading /usr/X11R6/lib/modules/drivers/fbdev_drv.o
(II) Module fbdev: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 0.1.0
   ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 XInput Driver
   ABI class: XFree86 XInput driver, version 0.4
(II) FBDEV: driver for framebuffer: fbdev, afb
(II) Primary Device is: PCI 01:00:0
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 0.0.2
   ABI class: XFree86 Video Driver, version 0.6
(EE) open /dev/fb0: No such device
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to .

If necessary, I can post the config file too.

Thanks in advance .

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
problems with the configuration of Xfree86
« Reply #4 on: January 18, 2004, 01:59:22 PM »
It seems that your vdo card is not supported by this version on your Xfree86.
BTW.. wht graphic card you are having ?

Offline GNUrag

  • Tux Awared
  • **
  • Posts: 41
    • http://tends.ourproject.org/~anurag
problems with the configuration of Xfree86
« Reply #5 on: August 07, 2004, 12:19:56 PM »
Debian has an excellent utility for reconfiguring Xserver.
# dpkg-reconfigure xserver-xfree86