February 27, 2017, 08:58:28 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: mic not working?  (Read 6 times)

Offline DarkGarnet

  • New Member
  • Posts: 1
mic not working?
« on: Today at 03:45:08 AM »
I'm trying to figure out whether my mic does or does not work, and if not, how I can make it work.

I opened my Sound preferences and looked under "input". The little green bars respond to the sound of my breathing. The mic also showed up fine on an online "check your mic" test. So it seems like it's working.

So I tried to take a recording of my voice with Audio Recorder; but when I played the file, I couldn't hear sound. Now, the application I played it with has an option to show a waveform of the sound being played. All it showed was a flat line, meaning that no sound was being played. I tried recording again, closer to the mic, but I got the same result when I tried to play it back.

Then I opened the Driver Manager, and it says "This device is not working." Okay, fine. But then why is it detecting sound online and when I have Sound Preferences open?

Does anyone know what is going on with this? Is there a way to fix it? Thanks in advance.

Offline dalek

  • LST CareTaker
  • Crescent
  • *****
  • Posts: 238
Re: mic not working?
« Reply #1 on: Today at 04:11:39 AM »
I would check to make sure your user is in the right groups.  I would check the permissions as well.  Given that it works in some programs, I would think those would be fine.  I don't know what desktop GUI you use but some handle permissions better than others.  Also, I know in the past, I have had to unmute the playing of audio in two separate programs.  For me, those would be alsamixer and Kmix.  Until I unmute both of those, no sound output.  Maybe the same is true for the mic??  Maybe there is two programs trying to control the mic??

I don't have a mic here so I can't give any real world experience.  I hope those ideas above will lead to something good tho.