December 15, 2017, 09:45:00 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: clamsmtp problem  (Read 1626 times)

Offline shipoin_97

  • Tux Awared
  • **
  • Posts: 44
clamsmtp problem
« on: May 18, 2006, 06:38:48 AM »
Friends ,
   I have littlebit trouble with "clamsmtpd " configuration . I have installed  clamsmtp-1.6.tar.gz in my  Redhat Linux Enterprise 4 server . When i have installed i can't get any "clamsmtpd.conf " in my pc using "locate "  .
   Then i make a "clamsmtpd.conf"  from my "clamsmtp-1.6 folder" and put it into "/usr/local/etc/" location . my configuration file is :

  # ------------------------------------------------------------------------------#                        SAMPLE CLAMSMTPD CONFIG FILE
# ------------------------------------------------------------------------------#
# - Comments are a line that starts with a #
# - All the options are found below with sample settings
# The address to send scanned mail to.
# This option is required unless TransparentProxy is enabled
OutAddress: 127.0.0.1:10026

# The maximum number of connection allowed at once.
# Be sure that clamd can also handle this many connections
#MaxConnections: 64

# Amount of time (in seconds) to wait on network IO
#TimeOut: 180

# Keep Alives (ie: NOOP's to server)
#KeepAlives: 0

# Send XCLIENT commands to receiving server
#XClient: off

# Address to listen on (defaults to all local addresses on port 10025)
Listen: 127.0.0.1:10025

# The address clamd is listening on
#ClamAddress: /var/run/clamav/clamd

# A header to add to all scanned email
#Header: X-Virus-Scanned: ClamAV using ClamSMTP

# Directory for temporary files
#TempDirectory: /tmp

# Whether or not to bounce email (default is to silently drop)
#Bounce: off

# Whether or not to keep virus files
#Quarantine: off
# Enable transparent proxy support
#TransparentProxy: off

# User to switch to
User: clamav

# Virus actions: There's an option to run a script every time a virus is found.
# !IMPORTANT! This can open a hole in your server's security big enough to drive# farm vehicles through. Be sure you know what you're doing. !IMPORTANT!
#VirusAction: /path/to/some/script.sh

    Now when i run , "/usr/local/etc/clamsmtpd.conf"  Then it shows :
/usr/local/etc/clamsmtpd.conf: line 11: OutAddress:: command not found
/usr/local/etc/clamsmtpd.conf: line 29: Listen:: command not found
/usr/local/etc/clamsmtpd.conf: line 50: User:: command not found

  Plz tell me what is the problem . Here i mention that my "clamsmtpd" and "clamd" both daemon are running properly . And my other configuration are also right .

        Plz plz help...........