Network Troublshooting > Linux Proxy Server Support

YAHOO CHAT ROOM through yahoo messenger using squid proxy

<< < (3/8) > >>

jp_durai:
I have squid with minimum configuration, I want to block Yahoo,MSN ....messanger from accessing

How to block? what are the changes have i to make in squid.conf.

Please reply

Ricky:
jp_durai ::
Please see this --> blocking yahoo and msn in squid proxy

aktiwari4u:
basically yahoo says that you chatroom or any other service which uses direct connection on bothend does not support any proxy though you are running it in transperent mode sitll its making a proxy connection with yahoo and in this case its not possible to connect to yahoo

ashishraj:
sanjeevlic
use squid as a transparent proxy ( squid+NAT )
and give DNS on your client machine as give ur ISP.
and in messenger >connection>no network detect

thats it  :P

ffidx:
My problem is that I want to enable voice chat in yahoo, when i try to connect my client behind squid to yahoo messenger with following options.

 1) No porxies------------->never connect(no error shown only trying for a while and then no result)

 2)firewall with no proxy------------------->connected but voice chat is not enable(no option for voice chat)

 3)use proxies---------------------->connected but again voice chat is not enable(no option for voice)

 4)No network detection----------->again failed to connect(no fate)

I've squid and firewall running on same machine
eth1 is my LAN side and eth0 is my Internet NIC.
configurations are

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 \
        -j REDIRECT --to-port 8080
iptables -A INPUT -j ACCEPT -m state \
        --state NEW,ESTABLISHED,RELATED -i eth1 -p tcp \
        --dport 8080
iptables -A OUTPUT -j ACCEPT -m state \
        --state NEW,ESTABLISHED,RELATED -o eth0 -p tcp \
        --dport 80
 iptables -A INPUT -j ACCEPT -m state \
        --state ESTABLISHED,RELATED -i eth0 -p tcp \
        --sport 80
iptables -A OUTPUT -j ACCEPT -m state \
        --state ESTABLISHED,RELATED -o eth1 -p tcp \
        --sport 80

and in the end I am using MASQUERADING which solve my msn problem but yahoo problem still presists.

plz guide me thanks

Regards,
FFIDX

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version