May 27, 2022, 07:04:39 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: NFS problem  (Read 3348 times)

Offline deven_01

  • Linux Learner
  • ***
  • Posts: 143
NFS problem
« on: August 12, 2005, 12:38:12 PM »
Hello friend
 I configured NFs properly, ut i got following error during mounting
 mount to NFS server '192.168.0.197' failed: server is down
 where 192.168.0.197 is my nfs server

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
NFS problem
« Reply #1 on: August 12, 2005, 05:02:07 PM »
Are you sure that NFS service is started on your server ?

Offline dragoncity99

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 551
NFS problem
« Reply #2 on: August 13, 2005, 09:11:26 AM »
Is your portmap service running?

If portmap is running, is nfsd (nfs daemon) running?

If nfsd can't run, is ur configuration file named "exports" have some typo error?

Offline deven_01

  • Linux Learner
  • ***
  • Posts: 143
NFS prolem
« Reply #3 on: August 13, 2005, 11:01:42 AM »
My server runnin properly
 I do following
 $service nfs start
 $service portmap start
 $rpcinfo -p
  it gives following as output
  program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  32769  status
    100024    1   tcp  32768  status
which indicates the portmap & nfs running properly
 But when i given following command on client machine \
 $rpcinfo -p mynfsdomain it gives following error
 rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused

Offline Abhishek_Jain

  • Linux Noob !
  • *
  • Posts: 8
nfs
« Reply #4 on: October 06, 2005, 06:19:55 PM »
hi,
  check whether nfs daemon is running on port 2049 on your server

Offline gauravbajaj

  • LST CareTaker
  • Experienced
  • *****
  • Posts: 658
NFS problem
« Reply #5 on: October 07, 2005, 06:42:42 AM »
Ok
Do one thing : give this command
#service portmapper status

Send me the output of this command

After that give this
#service portmapper restart

After that mount ur NFS Share ..If still pb come .. then just uninstall the portmapper and re-install it again....

After that it will work...

Gaurav