December 11, 2017, 05:57:27 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: No sound on redhat 7.3  (Read 2809 times)

Offline rajpal.gusain

  • Linux Noob !
  • *
  • Posts: 4
No sound on redhat 7.3
« on: July 18, 2005, 11:21:50 AM »
Here is the pci output
$ cat /proc/pci
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: PCI device 8086:2570 (Intel Corp.) (rev 2).
      Prefetchable 32 bit memory at 0xf0000000 [0xf7ffffff].
  Bus  0, device   2, function  0:
    VGA compatible controller: PCI device 8086:2572 (Intel Corp.) (rev 2).
     IRQ 11.
      Prefetchable 32 bit memory at 0xe8000000 [0xefffffff].
      Non-prefetchable 32 bit memory at 0xfeb80000 [0xfebfffff].
      I/O at 0xed98 [0xed9f].
  Bus  0, device  29, function  0:
    USB Controller: PCI device 8086:24d2 (Intel Corp.) (rev 2).
      IRQ 11.
      I/O at 0xff80 [0xff9f].
  Bus  0, device  29, function  1:
    USB Controller: PCI device 8086:24d4 (Intel Corp.) (rev 2).
      IRQ 10.
      I/O at 0xff60 [0xff7f].
  Bus  0, device  29, function  2:
    USB Controller: PCI device 8086:24d7 (Intel Corp.) (rev 2).
      IRQ 9.
      I/O at 0xff40 [0xff5f].
  Bus  0, device  29, function  3:
    USB Controller: PCI device 8086:24de (Intel Corp.) (rev 2).
      IRQ 11.
      I/O at 0xff20 [0xff3f]. Bus  0, device  29, function  7:
    USB Controller: PCI device 8086:24dd (Intel Corp.) (rev 2).
      IRQ 5.
      Non-prefetchable 32 bit memory at 0xffa80800 [0xffa80bff].
  Bus  0, device  30, function  0:
    PCI bridge: Intel Corp. 82820 820 (Camino 2) Chipset PCI (rev 194).
      Master Capable.  No bursts.  Min Gnt=2.
  Bus  0, device  31, function  0:
    ISA bridge: PCI device 8086:24d0 (Intel Corp.) (rev 2).
  Bus  0, device  31, function  1:
    IDE interface: PCI device 8086:24db (Intel Corp.) (rev 2).
      IRQ 9.
      I/O at 0x1f0 [0x1f7].
      I/O at 0x3f6 [0x3f6].
      I/O at 0x170 [0x177].
      I/O at 0x376 [0x376].
      I/O at 0xffa0 [0xffaf].
      Non-prefetchable 32 bit memory at 0xfeb7fc00 [0xfeb7ffff].
  Bus  0, device  31, function  2:
    IDE interface: PCI device 8086:24d1 (Intel Corp.) (rev 2).
  IRQ 9.
      I/O at 0xfe00 [0xfe07].
      I/O at 0xfe10 [0xfe13].
      I/O at 0xfe20 [0xfe27].
      I/O at 0xfe30 [0xfe33].
      I/O at 0xfea0 [0xfeaf].
  Bus  0, device  31, function  3:
    SMBus: PCI device 8086:24d3 (Intel Corp.) (rev 2).
      IRQ 3.
      I/O at 0xeda0 [0xedbf].
  Bus  0, device  31, function  5:
    Multimedia audio controller: PCI device 8086:24d5 (Intel Corp.) (rev 2).
      IRQ 3.
      I/O at 0xee00 [0xeeff].
      I/O at 0xedc0 [0xedff].
      Non-prefetchable 32 bit memory at 0xfeb7fa00 [0xfeb7fbff].
      Non-prefetchable 32 bit memory at 0xfeb7f900 [0xfeb7f9ff].
  Bus  1, device  12, function  0:
    Ethernet controller: PCI device 8086:100e (Intel Corp.) (rev 2).
      IRQ 9. Master Capable.  Latency=64.  Min Gnt=255.
      Non-prefetchable 32 bit memory at 0xfeae0000 [0xfeafffff].
      I/O at 0xdf40 [0xdf7f].

and when i do sndconfig i get ---

$ sndconfig                                  x
                      x A PCI sound card was found in    x
                      x your system. The details are:    x
                      x                                  x
                      x      Model: Intel Corp.|unknown  x
                      x device 8086:24d5

When i do OK it says
                                 x
                      x The Intel Corp.|unknown device  x
                      x 8086:24d5 is not supported.     x
                      x                                 x
                      x             lqqqqk              x
                      x             x Ok x              x
                      x             mqqqqj              x
                      x                                 x
                      x                                 x
                      mqqqqqqqqqqqqqqqqqqqqqqq

please help me configuring the card.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
No sound on redhat 7.3
« Reply #1 on: July 20, 2005, 05:15:00 PM »
hmm..

First you goto intel website and look if they have any suppport for it . then we will try to figure it out.

Offline rajpal.gusain

  • Linux Noob !
  • *
  • Posts: 4
sound coming but can't hear songs
« Reply #2 on: July 21, 2005, 07:11:49 AM »
i installed sound driver from OSS(open sound system). Now i can hear the sound but when i try to play songs in xmms or mplayer it gets hanged after a few seconds. What might be the reason.
Please help as soon as possible.