January 23, 2022, 10:26:00 AM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Using outlook with squid  (Read 7917 times)

Offline bahram741413

  • Linux Noob !
  • *
  • Posts: 5
Using outlook with squid
« on: January 18, 2004, 05:29:15 AM »
hi 2 all
I have squid proxy server in my office and my user authenticate with ncsa. Is it possible for me to allow my user that use outlook ? ( i can't use transparent squid )

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Using outlook with squid
« Reply #1 on: January 18, 2004, 09:57:35 AM »
Man! There is alwasy problem in accessing mail through a mail client in proxy. I found that using transparent proxy solve it. But in simple proxy you can still use it but it is little hit and try thing. Here at my place I set outlook to use proxy and entered the proxy server only in HTTP and HTTPs leaving other blank and i was able to use the outlook.
I just tested it !!
I suggest you to try using outlook only after authenticatioin.
Tell me how is you going..

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #2 on: May 25, 2004, 12:47:49 PM »
Where do you configure the proxy settings on outlook?

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #3 on: May 25, 2004, 01:11:22 PM »
Outlook 2002 that is

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Using outlook with squid
« Reply #4 on: May 25, 2004, 02:26:44 PM »
Hmm.. Not used outlook from long time, hwever only used last to check for this thread..
It is under account > and connection.. You can also set it to use internet explorer setting.

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #5 on: May 25, 2004, 02:36:18 PM »
Thanks for the quick response

just a quick questiion ricky

You would need two network cards to setup a transparent proxy right?

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #6 on: May 25, 2004, 02:51:57 PM »
my apologies once again, I only saw your sig afterwards.


Is it possible to run a transparent proxy with the following setup:

clients + proxy -------> hub -----> router --------> internet

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Using outlook with squid
« Reply #7 on: May 26, 2004, 10:56:05 AM »
It should be like..
Code: [Select]
clients ----> proxy -------> hub -----> router --------> internetYou can have proxy on machine with only one NIC.. as theoritically it is possible, but not transparent proxy.
It can be like this, Proxy box has router as gateway and other machine on local net uses proxy by configuring browser to use proxy.

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #8 on: May 26, 2004, 12:15:36 PM »
That is exatcly how it has been configured, everything works fine except  for that damned outlook. Maybe i should try another mail client.

Anyway thanks for all your help

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Using outlook with squid
« Reply #9 on: May 26, 2004, 12:30:53 PM »
y don't u access outlook directly through router ? ie.. as they are all connected directly to hub that is connected to router. .

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #10 on: May 27, 2004, 02:10:47 PM »
Thanks for all your help ricky.

I finally got it to work, it was something i had overlooked.

Is there anyway to force the clients to use the proxy with my current setup. It  works fine but it is still up to the client wether to use the proxy or not.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Using outlook with squid
« Reply #11 on: May 27, 2004, 03:15:09 PM »
Man... It is transparent proxy.. <--- Your solution

Offline johnnycash

  • Linux Noob !
  • *
  • Posts: 8
Using outlook with squid
« Reply #12 on: May 27, 2004, 03:29:18 PM »
I knew you'd say i that.

I hoped i was wrong.