December 14, 2017, 12:59:22 PM

News : LinuxSolved.com Linux Help Community Forum..


Author Topic: Squid Proxy and Ftp server  (Read 9620 times)

Offline rana28

  • Linux Noob !
  • *
  • Posts: 26
Squid Proxy and Ftp server
« on: January 13, 2005, 01:42:16 PM »
We are using squid proxy as internet sharing purpose, Our total node are 50,in all macines accessing net is fine but I am unable to connect our external ftp server through squid proxy, but when I tried to connect to ftp server from Linux server it is fine, what is the problem?

Offline cyberkoa

  • Linux Noob !
  • *
  • Posts: 4
Squid Proxy and Ftp server
« Reply #1 on: January 13, 2005, 10:25:02 PM »
I face the same problem as you , I hv search through the Internet and get a proposed solution , but it does not work fine for me , but you may try that


Add the following ACL in a proper place in the squad.conf, and restart


acl ftp_protocol proto FTP
always_direct allow ftp_protocol



Hope that it works for you.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Squid Proxy and Ftp server
« Reply #2 on: January 14, 2005, 10:38:44 AM »
You people have not told me that are you using transparent proxy or simple proxy ?
in simple proxy , set your ftp client to use port 3128 (or port on which squid is listening) as ftp port and also make sure your ftp client is in passive mode.

about FTP protocol , in acls we always allow port 21 so no to use that explicitly.

Offline cyberkoa

  • Linux Noob !
  • *
  • Posts: 4
Squid Proxy and Ftp server
« Reply #3 on: January 14, 2005, 03:16:12 PM »
Thanks Ricky, I found the cause of my problem already, I do not connect the FTP throught Passive Mode.
In fact, I am testing the FTP from IE , it do not allow Passive Mode (I am not sure whether there is a way or not) , and   I keep troubleshooting the squid , I thought is the Squid problem and yesterday only I realize this.

I am using tranparent proxy , following the tutorial giving by you , you indeed help me a lot .

Any way to allow FTP connection without Passive mode ?

I have another question on the authentication in tranparent proxy , I think I will post a new topic.
Hopefully can get your opinion ..

Offline rana28

  • Linux Noob !
  • *
  • Posts: 26
FTP Through Squid
« Reply #4 on: January 15, 2005, 08:31:22 AM »
Dear Friends,
Thanks for your reply, but my problem remains same. I am using simple proxy and configure my ftp client to use my proxy server 192.168.1.100 port 3128 and also add the line http_access allow !Safe_ports at squid.conf file.But the problem remains same, I am also unable to retrive my pop3 mail at outlook express, but all is possible at my linux server.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Squid Proxy and Ftp server
« Reply #5 on: January 15, 2005, 09:29:13 AM »
rana! what do you get .. ie no connection or something else..

?

Offline rana28

  • Linux Noob !
  • *
  • Posts: 26
Ftp hrough squid
« Reply #6 on: January 15, 2005, 09:56:09 AM »
I am accessing my external ftp server (web server) through ftp client cute ftp , its connect to my ftp server but I am unable to open any folder in my ftp server. there is time out message showing, but in my linux server it would oprn very quickly.

Offline Ricky

  • LST CareTaker
  • Specially Skilled
  • *****
  • Posts: 2381
Squid Proxy and Ftp server
« Reply #7 on: January 16, 2005, 01:04:10 PM »
is it time with "unable to retrive dirctory listings" ?
if that is then again same.. check that if your ftp client is working in Passive mode or not ! if no then set it to work in passive mode!

And passive mode is something which is decided by ftp server ie if it is runnning in passive mode then you can open the directories without being in passive mode but that will be slow , and in case of proxy will not work !

Offline ilias

  • Linux Learner
  • ***
  • Posts: 116
Squid Proxy and Ftp server
« Reply #8 on: June 16, 2005, 05:49:27 AM »
If u r using simple proxy,  just disable ur firewall by going to setup -->firewall configuration

It will work

Offline getviswa

  • Linux Noob !
  • *
  • Posts: 10
Re: Squid Proxy and Ftp server
« Reply #9 on: June 02, 2010, 07:13:30 AM »
try this ....
both simple or trans proxy disable the SElinux and try....

Offline getviswa

  • Linux Noob !
  • *
  • Posts: 10
Re: Squid Proxy and Ftp server
« Reply #10 on: June 02, 2010, 07:16:39 AM »
 to disablem selinux =====>  /etc/selinux/config