Linux in General > Linux Kernel

CRC error : kernel not getting loaded at the time of bootup

(1/1)

sekhar_vrc:
Dear sir
     

                I have intel-810 mother board with 96 mb sdram 10gb harddisk.
                I have loaded 3 operating systems win98/xp/redhat7.2
and all were working fine.

               i have changed 96mb(64+32) to 128 mb ram
and tried to load redhat9.0 but installation is not successful.
               Now i have loaded successfully redhat7.2 .
When i am trying to boot the following messages is appearing.

********************************
Booting 'Red Hat Linux (2.4.7-10)'

root (hd0,1)

        Filesystem type is ex2fs,partition type 0x83
kernek /boot/vmlinuz-2.4.7-10 ro root=/dev/hda2
    [Linux-bzImage,setup=0x1400, size=0xc2714]
initrd /boot/initrd-2.4.7-10.img
    [Linux-initrd @ 0x7e8f000, 0x50d4d bytes]

Uncompressing Linux....

crc error

--System halted

****************************

Any solution to the above problem will be highly appreciated.

looking for help
sekhar

gauravbajaj:
ok
hmm...., acc to me  Red Hat linux 7.2 have not sucessfuly installed
,actually to install red hat 7.2,  cylinder size must less than 1024 cylinders i.e u must make boot partision of 100 mb & note that it must be the first partision, i.e must lie before 1024 cylinders, after that u can create   / & swap partitions

bye

,

Ricky:
gaurav> I must admit here that you tried well to sort out the problem but what I think it is due to currupt data, as crc = Cyclic Redundancy Check which is a method of error correction.

So solution could be reinstall or repair using some live LINUX Cd and then repair filesystem.

You can use fsck to repair that partition and if that don't work then there was another method but don't remember that (rather command) !

gauravbajaj:
ok ricky
i think , u r true, as i haven't got this type of error,
so  shekar,try to reinstall or repair filesystem using fsck utility
try:
#fsck -A /dev/hda1(Linux root partition)

or use man fsck to learn more
i think it works

Navigation

[0] Message Index

Go to full version