Linux Forums - Linux Help,Advice & support

Linux in General => Linux Kernel => Topic started by: smb2004 on June 18, 2004, 04:30:36 PM

Title: make command
Post by: smb2004 on June 18, 2004, 04:30:36 PM
i am trying to get my wireless card to work, i download the drivers but i need to build them first.  the readme tells me to run 'make config'  when i do i get the response:
bash: make: command not found
this is suse 9.1, is the command different? or what is wrong any one?
Title: make command
Post by: aaa on June 18, 2004, 07:05:57 PM
Make sure you installed make, and gcc too (the software development tools)
Title: make command
Post by: smb2004 on June 18, 2004, 07:48:39 PM
can you be more specific as to where/how to install....newbie :wink:
Title: make command
Post by: dragoncity99 on June 19, 2004, 01:45:14 AM
After u extracted all the files and folders of the driver u have in hand. What u should do to install the driver is to hunt for the

README file and INSTALL file in ur driver folder. These two files are the guides for u to do the driver installation.
Title: make command
Post by: smb2004 on June 19, 2004, 03:09:38 AM
the readme tells me i need to run command 'make config'
Title: make command
Post by: dalek on June 19, 2004, 10:08:07 AM
You have to type make config when you are in the directory of the program.  I think you have to be root also.


:D :D :D :D
Title: make command
Post by: dragoncity99 on June 20, 2004, 10:03:24 AM
'make config' only?

Please show me the complete README/INSTALL file that gives u the instruction to install.

Then do as wat the README says step by step, please don't miss even a step.
Title: readme
Post by: smb2004 on June 21, 2004, 02:09:08 AM
here is the complete readme file:

* Copyright (C) 2001 AbsoluteValue Systems, Inc.  All Rights Reserved.
* --------------------------------------------------------------------
* linux-wlan
*   The contents of this file are subject to the Mozilla Public
*   License Version 1.1 (the "License"); you may not use this file
*   except in compliance with the License. You may obtain a copy of
*   the License at
*   Software distributed under the License is distributed on an "AS
*   IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
*   implied. See the License for the specific language governing
*   rights and limitations under the License.
*   Alternatively, the contents of this file may be used under the
*   terms of the GNU Public License version 2 (the "GPL"), in which
*   case the provisions of the GPL are applicable instead of the
*   above.  If you wish to allow the use of your version of this file
*   only under the terms of the GPL and not to allow others to use
*   your version of this file under the MPL, indicate your decision
*   by deleting the provisions above and replace them with the notice
*   and other provisions required by the GPL.  If you do not delete
*   the provisions above, a recipient may use your version of this
*   file under either the MPL or the GPL.
* --------------------------------------------------------------------
* Inquiries regarding the linux-wlan Open Source project can be
* made directly to:
* AbsoluteValue Systems Inc.
* --------------------------------------------------------------------
* Portions of the development of this software were funded by
* Intersil Corporation as part of PRISM(R) chipset product development.
* --------------------------------------------------------------------

The linux-wlan package is a linux device driver and subsystem
package that is intended to provide the full range of IEEE 802.11 MAC
management capabilities for use in user-mode utilities and scripts.
The package currently supports the Intersil 802.11b Prism2, Prism2.5,
and Prism3 reference designs for PCMCIA, PCI, and USB.  Additionally,
the package includes support for PLX9052 based PCI to PCMCIA adapter
with a few different PCMCIA cards.

For a list of elements that are still undone, see the TODO file in
this directory

See the COPYING and LICENSE files.

Top level directory for linux-wlan-ng:
./add-ons   - additional programs that are not build from the
                  top level make file
./doc      - source distribution documentation
./etc      - scripts used at run-time
./man      - man pages
./scripts   - contributed scripts that may do useful things
./src      - source code for various components

Build Instructions:

NOTE: You may not need to build at all.  Binary packages are
available for various distributions.  See the FAQ for where to go.

NOTE: This release supports building four different drivers:

   prism2_cs   Driver for Prism2.x & Prism3  PCMCIA cards.
   prism2_pci   Driver for Prism2.5 (ISL3874) based _native_ PCI cards.
   prism2_plx   Driver for Prism2.x PCMCIA cards when used with
      a PLX9052 PCI/PCMCIA adapter.
   prism2_usb   Driver for Prism2.x USB adapters.


To build linux-wlan-ng you will need:
   - Configured kernel source code for the kernel you are running.  
     Ideally, this will be the resulting tree after building your own
     kernel.  Configured means that you have at least run 'make config',
     'make menuconfig', or 'make xconfig'.  If you are trying to build
     linux-wlan-ng for a previously existing kernel binary (one you did
     not build yourself), look for help on the mailing lists because it
     can be tricky.  I always run against kernels I've built myself, so I'm
     not much help in this area.
   - The good David Leffler identified that if you are having difficulty
     with *_netlink_* symbols, you may have a problem with 'make clean' in
     the kernel tree.  Do a 'make mrproper' followed by 'make config'
     and the rest of the kernel build process.  'make mrproper' does
     a more thorough cleaning of the kernel tree.  For more info, look
     for David's comments in the linux-wlan-user mailing list.
   - If you are building a driver for a PCMCIA card, you will also need
     the configured PCMCIA source code for the pcmcia_cs subsystem you
     are currently running.

Building linux-wlan-ng:

1)  untar the package using the command:

    tar zxvf linux-wlan-ng-X.Y.Z.tar.gz

2)  Make sure you have configured kernel and (optionally) pcmcia sources on
    your system.  Note that if you are _only_ building the prism2_pci,
    prism2_plx, or prism2_usb drivers you don't need the pcmcia-cs
    source tree.

3)  To configure the linux-wlan-ng package, run 'make config'.  The
    following set of questions will be asked. The default answer is in
    braces (e.g. []).  Just press <Enter> to select the default answer:

   - "Build Prism2.x PCMCIA Card Services (_cs) driver? (y/n) [y]: "
        Select "y" if you want to build the Prism PCMCIA driver.
        If you select "n", the PCMCIA related questions below
        will not be asked.

   - Build Prism2 PLX9052 based PCI (_plx) adapter driver? (y/n) [y]:
        Select "y" if you want to build the Prism driver for
        PLX PCI9052 PCI/PCMCIA adapter based solutions.

   - Build Prism2.5 native PCI (_pci) driver? (y/n) [y]:
        Select "y" if you want to build the Prism driver for
        Prism2.5 ISL3874 based native PCI cards.  This includes
        PCI add-in cards and the mini-pci modules included in some
        notebook computers (but not all, some use internal USB modules).

   - Build Prism2.5 USB (_usb) driver? (y/n) [y]:
        Select "y" if you want to build the Prism driver for
        Prism2.5 ISL3873 based USB adapters.  This includes
        USB add-on modules and the internal modules included in some
        notebook computers.

   - Linux source directory [/usr/src/linux]:
        The config script will attempt to automagically find your kernel
        source directory.  If found, the kernel source source directory
        will be presented as the default selection.  If the default
        selection is wrong, you may correct it here.

   - pcmcia-cs source dir [/usr/src/pcmcia-cs-3.1.29]:
        If the "_cs" driver is selected above, the configure script will
        attempt to present a reasonable default for the pcmcia source
        directory.  If the presented directory is incorrect, you may
        change it here.  If the "_cs" driver is not selected, this
        prompt will not appear.

   - PCMCIA script directory [/etc/pcmcia]:
        If the "_cs" driver is selected, this prompt allows you to
        change the location where the pcmcia scripts will be installed.
        Only do this if you have installed the rest of the pcmcia_cs
        scripts to a non-default location.

   - Alternate target install root directory on host []:  
        This prompt allows you to specify an alternative root directory
        for the install process.

   - Module install directory [/lib/modules/2.2.20]:
        Select where you want the driver modules to be installed.  The
        script constructs a default location using the output of uname.
        If you have not yet installed the kernel you will run linux-wlan
        with, and the new kernel has a different version string, you will
        need to change this value.

   - Prefix for build host compiler? (rarely needed) []:
        When cross-compiling or using different compilers for kernel and
        user-mode software, it is sometimes (but rarely) necessary to
        specify a different compiler prefix to use when compiling the
        _tools_ that are built to run on the build host during the
        linux-wlan-ng build process.

   - Build for debugging (see doc/config.debug) (y/n) [y]:
        This option enables the inclusion of debug output generating
        statements in the driver code.  Note that enabling those statements
        requires the inclusion of insmod/modprobe command line arguments
        when loading the modules.  See the document doc/config.debug
        for more information.

5)  To build the package, run 'make all'

6)  To install the package, run 'make install' (as root).


NOTE:  linux-wlan-ng does not fully implement the wireless extensions
       interface.  This means that you can't use iwconfig and its kin to
       set things up.  Instead, read on!

As of linux-wlan-ng 0.1.16-pre5, the configuration and launch scripts have
been largely re-written.  pcmcia/rc/hotplug now all use a common library
of routines and use the same set of configuration files.

Now, everything relevant exists in /etc/wlan/*


   This file maps between wlan devices and network IDs, and contains
   the names of all devices that should be initialized by the hotplug
   and rc scripts.


   These files are per-network configurations.  This makes it easy to
   switch between different SSIDs and the various settings they may
   require, like WEP keys and whatnot.

The bare minimum you need to do to configure your system after a fresh driver

0)  Nothing whatsoever.  out-of-the-box, the driver will attempt to associate
    with any access point within range.

However, we highly recommend setting up a configuration specifically for
your network, using the following method:

0)  This example assumes your network name/SSID is "MyHomeNetwork"
1)  cp /etc/wlan/wlancfg-DEFAULT /etc/wlan/wlancfg-MyHomeNetwork
2)  edit /etc/wlan/wlan.conf and change the SSID_wlan0 line to:
3)  edit /etc/wlan/wlancfg-MyHomeNetwork, and make any necessary changes
    necessary to support your network, such as WEP and whatnot.

A)  Edit /etc/pcmcia/network.opts file to set up your IP settings.
    Note: for a station, the SSID you're connecting to will be appended to the
    current pcmcia scheme name.  You can use this to have different
    IP setups for different wireless LANs you connect to (e.g. home vs. work).

    Note2:  This only applies if you are using a stock pcmcia-cs
    package.  Most (if not all) distros use their own mechanisms for
    configuring pcmcia network interfaces, and thus
    /etc/pcmcia/network.opts may not even be present.

B)  Restart pcmcia-cs with the command:

    /etc/rc.d/init.d/pcmcia restart

C) Insert the card.  For most cards, a solid LED indicates that the
    SSID you specified was found, a bss was joined, and the firmware
    completed the authenticate and associate processes.

D) Run ifconfig and route to determine if your IP and route settings are
    listed as you wanted them.  It's also a good idea to look at the file
    /etc/resolv.conf to see if your nameserver address has been set up

A) You must make sure that the drivers get loaded at boot time and that the
   necessary initialization takes place.  The simplest way to do this is
   to add the following commands to your rc.local file:

     modprobe prism2_pci   [or prism2_usb/prism2_plx]
     wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
     wlanctl-ng wlan0 lnxreq_autojoin ssid=<your APs SSID> authtype=opensystem
     ifconfig wlan0 <yourIP> netmask <yourNetmask> broadcast <yourBroadcast>
     route add default gw <yourGateway>

   Also, don't forget to set up your resolv.conf to point at your DNS server.

B) Alternatively, you can use the rc.wlan script, which ties into the
   /etc/wlan/* configuration files mentioned above.

   We currently don't create the softlink from the runlevel directories to
   the wlan startup script due to differences in distributions, but the
   scripts are redhat-aware, and can be extended to hook into other tools
   easily.  (patches welcome!)  Just make sure it is brought up early in
   the process, namely, before the the network interfaces are brought up.

C) Add an alias for wlan0 in /etc/modules.conf.  For example, a usb
   interface on wlan0 would be set up as:

   alias wlan0 prism2_usb

   Substitute prism2_plx or prism2_pci as appropriate.


A) Make sure your kernel usb support is running
B) Plug in the Prism2.x USB device
C) Run 'modprobe prism2_usb prism2_doreset=1' to load the driver into memory.
D) Run 'wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable' to initialize the
   driver+MAC functions.
E) Run 'wlanctl-ng wlan0 lnxreq_autojoin ssid=<your ssid> authtype=opensystem'
   to enable the MAC in Infrastructure Station mode.
F) Run 'ifconfig wlan0 <your IP address>'

Or, you can use the provided hotplug scripts, if your distribution has
hotplug support.  :)

IMPORTANT: Due to an issue with some versions of the Prism USB firmware,
the driver usually needs to perform a port reset.  

Some combinations of usb low-level drivers, kernel releases, and
hardware don't like this, and usually end up generating a kernel OOPS.
newer kernels are much better in this regard.  In particular, Intel usb
controllers are the most trouble-prone.

The OOPS is due to bugs in the linux USB core, and newer kernels
(2.4.19 and later) behave much better in this regard.

However, the good news is that primary firmware 1.1.2 seems to resolve
the need for the port reset to begin with.  Contact your vendor to
request this update.

Also, using the 'Alt. UHCI' controller driver (uhci.o) is broken with
kernels older than 2.4.22 due to a bug in the controller driver.
Title: make command
Post by: dragoncity99 on June 21, 2004, 03:48:25 PM
OIC, got it. Thanks u very much dalek, here actually from what i understand is there is two 'make config'

First one refers to recompiling the kernel.

Second one refers to compiling the sources in the tar.gz files.

Regarding ur installation on SUSE 9.1, i havent really used SUSE b4 but, the sources is architecture free unlike RPMs in Red Hat/Fedora. So everything is fine. Just follow the README, it's quite straightforward. Any problems feel free to discuss with me or others as well? ;)
Title: make command
Post by: smb2004 on June 22, 2004, 03:49:23 AM
the prob is i cant get past step three with the make config not working, read first post
Title: make command
Post by: dragoncity99 on June 22, 2004, 05:01:34 AM
Make command not found. IC, have u installed the compiler libraries such as glibc?
R u a root user doing this installation?
Are u in the current installation directory?
Title: make command
Post by: smb2004 on June 22, 2004, 02:15:13 PM
i am root and am in the correct folder for install, the compiler libraries im not sure about that, i'll try to install those
Title: make command
Post by: dragoncity99 on June 23, 2004, 01:08:08 AM
Ok, good. For me, when i install linux, i always make sure my linux installs "ALL" the library files though it will take quite a space on it.
Title: make command
Post by: smb2004 on June 24, 2004, 07:51:38 PM
i did an online update and downloaded all of the liberaries, i have glib2 i think the one suggested above.  i went again into terminal and tried to install and again i get:

bash: make: command not found

what am i missing? anyone?
Title: make command
Post by: dragoncity99 on June 25, 2004, 02:10:46 AM
U r missing the path to the executable commands in "/bin" and "/sbin" directory.

U can do a check by typing command:
echo $PATH

And what u suppose to get is something like this:

If u dont have the u should make ur Linux do so by doing so:
U must be a root :)

1. Open a new terminal and go to "/root" directory
2. Edit ".bash_profile" file in the /root directory. Type ---> "vi .bash_profile"
3. Add the following lines to add new entries (Type: Press "insert" key to enable edit):
    export PATH=$PATH:/bin  
    export PATH=$PATH:/sbin
4. Save and exit. (Type: Shift+zz to save and exit)

That's all.
Title: make command
Post by: smb2004 on June 25, 2004, 06:03:07 PM
i tried this is what i got:

# echo $PATH
# /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bim:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/java/jre/bin
# cd /home/Matt/linux-wlan-0.2.0
/home/Matt/linux-wlan-0.2.0 # make config
bash: make: command not found

did i miss a libarary or should i try the four steps you listed below?
Title: make command
Post by: dragoncity99 on June 27, 2004, 04:48:51 PM
Ur path looks fine.  R u a root or a superuser? If u r a super user, i fear u will have a hard time though installations are not encouraged as root.
I think u haven't configure yet ur files. Try the command :


first.  Does it work?
Title: make command
Post by: smb2004 on June 27, 2004, 10:05:43 PM
i didnt know the difference between root and su, so i've been going back and forth....also what directory to i run ./configure
Title: make command
Post by: dragoncity99 on June 28, 2004, 10:28:34 AM
root is like the "Administrator" in windoze.

su = super user of the OS, they have the privilege of the root if the are activiated.

For a root to login to linux. Just type "root" as a username for login and type the password to login.

./configure is executed under the program folder which u want to make the driver.
Title: make command
Post by: smb2004 on June 28, 2004, 08:53:28 PM
logged in as root:
/home/matt/linux-wlan-0.2.0 # ./confiure
bash: ./configure: no such file or directory

Title: make command
Post by: dragoncity99 on June 29, 2004, 03:08:40 AM
Ok, very good.

Can u send me a link or *.tar.gz file  that u have for this driver, i will try to see all the files available and test on my pc.

Thanks u very much ;)
Title: make command
Post by: smb2004 on July 01, 2004, 08:22:13 PM
the driver is for my dlink 520 wireless nic, i e-mail dlink and this is where they sent me for a driver:
Title: make command
Post by: dragoncity99 on July 03, 2004, 01:38:53 AM
I try to install ASAP for u.
Title: make command
Post by: smb2004 on July 09, 2004, 07:48:17 PM
hows that workin for ya?
Title: make command
Post by: dragoncity99 on July 10, 2004, 01:12:18 AM
I used this file:


What i did was :

1. tar -xzvf linux-wlan-ng-0.2.0.tar.gz

2. cd into this direcotry linux-wlan-ng-0.2.0

3. i type : "./Configure"

4. And if successfull, u can do make things.
Title: make command
Post by: smb2004 on July 12, 2004, 10:25:36 PM
thanks that did it! just one more thing, after the first 4 questions it asks for the source directory and it gives a default one of /use/src/linux that doesn't work for me.  do you know what it would be on suse linux?
Title: make command
Post by: dragoncity99 on July 13, 2004, 02:29:35 AM
Congratulations , good to hear that.
Most welcome ;)

Sorry, i never used SUSE before but, this option u can try to find which is the directory for SUSE to store the source codes.

Try this command to locate the source directory, it might help
1. type "updatedb"
2. type ----> locate "src"  (src or other few keywords)

Optionally u may search the net or go to SUSE main tech site to see the file system structure to identify it.
Title: make command
Post by: smb2004 on July 13, 2004, 11:55:59 PM
im still havin trouble finding the source directory, what should it have in it.  also im installing a second driver for somthing else and when i run './configure' it starts then errors and wants to know the host system type, what would go there?
Title: make command
Post by: dragoncity99 on July 14, 2004, 10:03:27 AM
What's that something else?
Title: make command
Post by: smb2004 on July 14, 2004, 04:46:53 PM
it is a vcd imager add on for k3b
Title: make command
Post by: dragoncity99 on July 15, 2004, 04:59:45 PM
Any links i can refer to the Add-on? I mean those u use to try to setup.
Title: make command
Post by: smb2004 on July 15, 2004, 09:14:32 PM
here are two links:

all i want to do i burn vcd and dvd's but my k3d cant do that yet.
if you know of anyother progams that would work too.
Title: make command
Post by: zerogood on August 30, 2004, 01:58:38 PM
just a question and i probably sound retarded i've been trying to figure out where to type 'make config' and now i understand that its a program or atleast from what i read i think it is.
Title: make command
Post by: zerogood on August 30, 2004, 08:29:41 PM
i've figured out that 'make config' is something i have to type somewhere but when i go into the folder i've extracted the wlan thing to i can't find the make config file so i went to terminal and type in make config but it says "make: *** no rule to make target 'config'. stop.
Title: make command
Post by: /root on May 11, 2005, 02:47:16 PM
to dragoncity:

hey dude, i'm new here and this is my first post

i hv the similar problem here where i also tried to install the wlan-ng driver for my pcmcia (Allied Telesyn) in Fedora core 3.

my questions are:
1) is "./configure" an executable file ???
2) when i tried the command:
    [root@localhost wlan-ng-1.1-pre5] # make config

The default responses for each question are correct for most users.
Consult the PCMCIA-HOWTO for additional info about each option.

Linux kernel source directory [/usr/src/linux]:
Linux source tree '/usr/src/linux' is incomplete or missing!
    See the HOWTO for a list of FTP sites for current kernel sources.

Configuration failed.

make: *** [.prereq.ok] Error 1

how can i fixed it??? i had googled it before but it is too difficult for me to understand it as linux is still a stranger for me. :cry:

i think 2) is the main portion that make me can't keep on my work  :? so dragoncity, can u help me to solve these problems????

thanks in advance,